Why is there private ip address in place of default gateway ip?

Messages
6
Below was trace of google.com few months ago.

1 <1 ms 1 ms <1 ms Home [192.168.1.1]
2 34 ms 33 ms 32 ms 117.215.x.x
3 36 ms 35 ms 33 ms 218.248.170.118
4 42 ms * 48 ms 218.248.235.197
5 * 42 ms 40 ms 218.248.235.198
6 42 ms 42 ms 41 ms 74.125.48.138
7 42 ms * 44 ms 108.170.248.177
8 42 ms 41 ms 40 ms 209.85.251.29
9 41 ms 40 ms 41 ms google.com [216.58.203.142]

2nd row represent default gateway ip which match assign ip (117.215.x.x.)

Below is my current trace of google.com

1 1 ms <1 ms <1 ms Home [192.168.1.1]
2 30 ms 30 ms 34 ms 10.217.x.x
3 31 ms 31 ms 32 ms 218.248.101.30
4 35 ms 34 ms 35 ms 218.248.235.197
5 35 ms * * 218.248.235.198
6 37 ms 38 ms 37 ms 74.125.48.138
7 * * * Request timed out.
8 37 ms 37 ms 37 ms 209.85.246.4
9 35 ms 35 ms 35 ms 108.170.248.219
10 64 ms 60 ms 59 ms 209.85.251.95
11 63 ms 63 ms 64 ms 74.125.242.145
12 68 ms 66 ms 66 ms 74.125.252.209
13 60 ms 61 ms 61 ms maa05s09-in-f14.1e100.net [172.217.166.110]

My ip is 117.215.x.x. So default gateway ip must be 117.215.x.x. But it is private range ip 10.217.x.x.

Even though dynamic ip in different range like 59.x.x.x , 61.x.x.x default gateway ip is remain same.

Does someone snooping?

Can someone explain this?
 

varkey

Regulars
Messages
917
I am not sure exactly, but my guess is that the gateway has multiple interfaces and it shows the IP address of the interface the traffic exits, this need not be the same as the IP address of the gateway on your side.

Secondly in a point to point link, the gateway IP address need not be on the same subnet at all. This page has more details on it -- How would a router with /32 WAN subnet mask communicate with the rest of the Internet?

Perhaps BSNL made some changes to their network infrastructure recently which caused this, however there is nothing to worry and this is working as designed. I am on FTTH and I see the same behaviour.
 


Messages
6
varkey thank you,

May be you are right about BSNL infrastructure change.

As you told there is nothing to worry. Ok fine:)

But it increase latency and the day it get private ip , iam unable to see real time data usage on this link http://172.30.139.25:9090/ssssportal/

this link give me "Location not found using Framed IP Address ".

already told JTO about this , he answerd i am first to concern about this and really do not know this thing.

already searched it in BSNL BROADBAND thread but find nothing.

i remember in one of thread somebody comping that he/she also not able to see real time data usage .
 
Messages
6
varkey, i tried your link . it's response is "user profile not found" . I think it is for FTTH user.

Also read your conversation with BSNL and Jyothish Kumar @ blacklightpyon twitter. It is good that your complain solved.

Here, I request to BSNL Broadband users if possible please share trace of google dot com.

For Whom who does not know how to.

Steps to perform trace. Click on Microsoft Start Button. -->Type CMD. -->Click on cmd dot exe -->Write tracert google dot com. --> Enter .
 


AgentX

The Secret Agent
Regulars
Messages
492
Location
Chennai
Something definitely changed for ADSL users. I also get a private gateway IP now.

Code:
  1    <1 ms    <1 ms    <1 ms  erx
  2    16 ms    15 ms    16 ms  10.208.120.1
  3    17 ms    29 ms    18 ms  static.ill.218.248.61.122/24.bsnl.in [218.248.61.122]
  4    18 ms    18 ms    17 ms  218.248.235.161
  5    55 ms     *        *     218.248.235.162
  6    32 ms    33 ms    36 ms  72.14.195.21
  7    26 ms    30 ms    36 ms  74.125.242.145
  8    44 ms    48 ms    38 ms  216.239.54.159
  9    57 ms    57 ms    56 ms  maa05s10-in-f3.1e100.net [216.58.200.131]
However, nothing's changed as far as public IP is concerned. Still get a /32 assigned on my PPPoE interface so forwarding et all work as usual.
 

Top