Want to connect D-Link router to BSNL ftth

Need settings for PPPOE for D-Link DSL 2750u
This modem is a ADSL modem. You need to connect this modem to ONT provide by BSNL FTTH. Then follow the link to use it a WI-FI router.

If this doesn't work, buy a wifi router (without ADSL) and connect it to ONT.

mayank yadav

ok, So i have the exact same setup. First you need to make your D-Link router to work with WAN. You won't be able to put pppoe settings in the dlink router since hg850a cannot be used in bridge mode. So after following all the steps in the link provided above , follow the following steps.

1) Connect LAN wire from HG850a(LAN 1) to dlink(LAN 4)

2) Then access the Dlink admin page via a laptop/desktop over lan.

3)Go to this page and change all the values and make them as shown in the picture.
This is to make sure that your dlink's admin page remains accessible on after enabling bridge mode on dlink

4) Go to internet setup in dlink admin page, click on Ethernet then click add.

5)Select protocol as bridging and click apply.

So now your network setup should be
Fiber-> ONT -> Dlink[LAN4](bridge mode) -> all other devices.
for portforwarding, you need to download an app on your android phone
Then connect your phone via wifi , it you followed all steps correctly then it should be assigned IP via the ONT since dlink is only in bridge mode.
open the app -> Click on plus sign on top right corner-> enter some random name -> enter the public and private port -> enter the IP address of the system from which you are hosting something which requires port forwarding(probably the IP address of your laptop/desktop/gaming console.) it should be 192.168.100.xxx -> select TCP and click add port forwarding.
Last edited:

mayank yadav

sadly hg850a does not support bridge mode as per my knowledge that is why we can't use dlink's admin panel to forward ports. hence you need that app to enable portforwarding via UpNp on hg850a.
hg850a does support portforwarding but they did not give us the interface to manage ports. also make sure that UpNp is ticked in hg850a's admin panel.
Last edited: