Unable to make Vowifi calls on Jio Fiber Connection

sudipt123

Internet Addict
Messages
212
Location
NA
ISP
Airtel Broadband
Hi All,

As per the subject, I am unable to make vowifi calls on both Airtel and Jio Network via my home Jiofiber connection. Jio CC not providing me with DNS IP's. Tried using cloudfare and google DNS, but unable to make it work. Also enabled IPSec Passthrough in Router settings.

TIA
 
Solution
Hi Guys, Finally managed to get vowifi working over Jiofiber. A big thankyou @gvkr for the detailed analysis with patient timely responses. FYI have a JCOW401 black Jio router.

1. Route version ARCTF1_JCOW401_R1.24 (updated recently)
2. Got this working over cloudfare IPv4 DNS with Primary DNS Server: 1.1.1.1 and Secondary DNS Server: 1.0.0.1
3. Added it through the WAN IPv4 settings under search

This time it miraculously worked (had set the same Cloudfare DNS earlier on R1.16 firmware)

Please mark this thread as resolved.

sudipt123

Internet Addict
Messages
212
Location
NA
ISP
Airtel Broadband
@gvkr Thanks for the analysis. So do you mean to use a manual DNS entry in the router. Since I already tried using cloudfare and Google DNS. I have access to my Co. VPN located in India if that helps? So even after connecting to Indian VPN, below is the nslookup response

C:\Users\sudiptc.ttl.TMINDIA>nslookup epdg.epc.mnc861.mcc405.pub.3gppnetwork.org
Server: tmpnevinf02.tmindia.tatamotors.com
Address: 128.9.51.189

Non-authoritative answer:
Name: epdg.epc.mnc861.mcc405.pub.3gppnetwork.org
Addresses: 49.44.59.36
49.44.59.38


C:\Users\sudiptc.ttl.TMINDIA>nslookup vowifi.jio.com
Server: tmpnevinf02.tmindia.tatamotors.com
Address: 128.9.51.189

Non-authoritative answer:
Name: vowifi.jio.com
Addresses: 49.45.63.2
49.45.63.1

Any clues from the above?
 
Upvote 0
Messages
31
Location
Hyderabad
ISP
Airtel Fiber
Yes, I would suggest you to use a manual DNS in router and do test again by nslookup.

In your company VPN, vowifi.jio.com is resolving through Singapore/foreign DNS servers hence it is not resolving to IP addresses 49.44.59.36, 49.44.59.38. [Jio has kept this check to ensure no abuse of vowifi during International Roaming].. The other one epdg.epc.mnc861.mcc405.pub.3gppnetwork.org is working fine in this VPN.

I would like you to change the DNS server to cloudflare/Google in your router and then test through nslookup command, both addresses should resolve to 49.44.59.36 or 49.44.59.38.[If still not working, check in What's My DNS Server? to ensure that Router is indeed sending DNS requests to the new DNS]. If DNS issue is ruled out, then we can test the router by probably connecting to free VPN where vowifi will work.
 
Upvote 1

sudipt123

Internet Addict
Messages
212
Location
NA
ISP
Airtel Broadband
So I changed the router DNS to Cloudfare and upon nslookup vowifi.jio.com its getting resolved to above IPs

C:\Users\sudiptc.ttl.TMINDIA>nslookup vowifi.jio.com
Server: reliance.reliance
Address: 192.168.29.1

Non-authoritative answer:
Name: vowifi.jio.com
Addresses: 49.44.59.36
49.44.59.38
--------------
However when i use the DNS lookup inside the router admin page, i get below response

Server: 1.1.1.1
Address: 1.1.1.1#53

** server can't find vowifi.jio.com: NOTIMP

------------
What's my DNS gives below readings

Your DNS Server49.45.31.133
Owner of this serverReliance Jio Infocomm Limited
Status of this serverEverything is fine
Your DNS Server162.158.234.23
Owner of this serverCloudflare, Inc.
Status of this serverEverything is fine
 
Upvote 0

sudipt123

Internet Addict
Messages
212
Location
NA
ISP
Airtel Broadband
Hi Guys, Finally managed to get vowifi working over Jiofiber. A big thankyou @gvkr for the detailed analysis with patient timely responses. FYI have a JCOW401 black Jio router.

1. Route version ARCTF1_JCOW401_R1.24 (updated recently)
2. Got this working over cloudfare IPv4 DNS with Primary DNS Server: 1.1.1.1 and Secondary DNS Server: 1.0.0.1
3. Added it through the WAN IPv4 settings under search

This time it miraculously worked (had set the same Cloudfare DNS earlier on R1.16 firmware)

Please mark this thread as resolved.
 
Upvote 0
Solution
Messages
1
Location
Pune
ISP
Jio Fiber
I am also facing the same issue, I am on R1.16 firmware. Can you please guide me how can I fix the issue on this firmware.

Alternatively, can you tell me how do I upgrade to R1.24 firmware.
 


Upvote 0

sudipt123

Internet Addict
Messages
212
Location
NA
ISP
Airtel Broadband
The R1.16 firmware is broken, it won't support vowifi. I don't know a method to force update the JIO ONT. Guess you'll have to wait for the update. Or you can try with a spare router if lying around.
 
Upvote 0
Messages
2
Location
Raipur
ISP
Jio Fiber
I was facing the same issue. Also I had issues while connecting to VPNs using the IKeV protocol. Their IPSec tunnel is broken in R1.16 firmware. I had complained about VoWifi not working using twitter and they lodged a complaint and the local team visited and updated the firmware to R1.24 and the IPSec tunneling issue has been fixed in this update.
 
Upvote 0
Messages
1
Location
Mumbai
ISP
Jio
Hi Guys, Finally managed to get vowifi working over Jiofiber. A big thankyou @gvkr for the detailed analysis with patient timely responses. FYI have a JCOW401 black Jio router.

1. Route version ARCTF1_JCOW401_R1.24 (updated recently)
2. Got this working over cloudfare IPv4 DNS with Primary DNS Server: 1.1.1.1 and Secondary DNS Server: 1.0.0.1
3. Added it through the WAN IPv4 settings under search

This time it miraculously worked (had set the same Cloudfare DNS earlier on R1.16 firmware)

Please mark this thread as resolved.
Is it possible to share the updated firmware or a link from where it can be downloaded, I'm struck with version 1.1 and in that Jio Calls are not working through the phone line.
 
Upvote 0

sudipt123

Internet Addict
Messages
212
Location
NA
ISP
Airtel Broadband
Sorry for the delayed reply, I don't think JIO has a downloadable firmware site nor possible to take a backup from ONT. There are 2 files for manual firmware update: 1. bin file 2. sig file. Your best bet is to log a complaint with Jio/ contact them on twitter for an update.
 
Upvote 0
Messages
2
Location
Rajahmundry
ISP
Jio fiber
Hi Guys, Finally managed to get vowifi working over Jiofiber. A big thankyou @gvkr for the detailed analysis with patient timely responses. FYI have a JCOW401 black Jio router.

1. Route version ARCTF1_JCOW401_R1.24 (updated recently)
2. Got this working over cloudfare IPv4 DNS with Primary DNS Server: 1.1.1.1 and Secondary DNS Server: 1.0.0.1
3. Added it through the WAN IPv4 settings under search

This time it miraculously worked (had set the same Cloudfare DNS earlier on R1.16 firmware)

Please mark this thread as resolved.
iam also having the same issue

recently i had installed the jio fiber connection with jio router iam unable to use wifi calling but with another isp iam able to use wifi calling please help me!
iwas already tried changing dns servers to 8.8.8.8 (8.8.4.4) and 1.1.1.1 (1.0.0.1) but there is no use

please help
 
Upvote 0