TataPlay Fiber does not provide True Static IPv6 (Asus Engineer)

  • Thread starter tatyasky
  • Start date
  • Replies 16
  • Views 3,609
tatyasky

tatyasky

Messages
416
Location
Mumbai
ISP
TataPlay & Jio
My Asus router when connected in Bridge Mode was not getting it's own IPv6. From below screenshot, you can see that my Asus Router does not get it's own WAN IPv6. That filed remains blank. All other devices on network however get a temporary IPv6. Below is my router's screenshot.

hqxT8oB.png



With month long email echange with remote access to my PC, Asus engineers found out that TataPlay ISP is to blame. The concluding email is as follows.

Hi Tatyasky,

So when you use the PC to directly connect to the connection line provided by the ISP, it can only be set to Static IPv6.
But when you connect to the connection line provided by the ISP through the Router, it can only be set to Native IPv6.
Is there anything wrong with this that there are two ways to set up IPv6?

Do you set "Automatic IP" or "PPPoE" in "WAN Connection Type" in "WAN - Internet Connection" page?
In general, if "Automatic IP", the setting in IPv6 should be "Passthrough".
If it is "PPPoE", it should be selected as "Native".

And if you select "Native", it seems that because your ISP does not provide "Non-temporary Address", the Router cannot obtain the WAN IPv6 Address, but only LAN IPv6 Address.
Although the LAN IPv6 Address can also connect the Router or the LAN Client to the IPv6 network normally, the DDNS function must be operated through the WAN IPv6 Address, so you cannot use this function.
You may need to discuss with your ISP company why there is no "Non-temporary Address" in their DHCPv6 packets.

Thank you.


Best regards,

Kengi Peng (彭冠傑)


The statement in Bold says it all.

When it works correctly (Someone's image of non-Indian ISP), one gets a proper WAN IPv6. Below is their screenshot for comparison.

avBTMm4.png


Some forum members tell that ours is correct implementation of static IPv6. Apparently NOT !!!! BTW IPv6 stops working if set as Passthrough mode like the above screenshot.
Indian ISPs are slowly pissing me more and more day by day.
 
T

TheCoolDean

Messages
72
Location
Bangalore
ISP
ACT
Not sure if this is gonna help, I'm not tech savvy, but here's a screenshot with my ACT connection.

09MDoS5.png
 
tatyasky

tatyasky

Messages
416
Location
Mumbai
ISP
TataPlay & Jio
@TheCoolDean This means ACT has correct IPv6 implementation where they allow Non-Temporary addresses in DHCPv6. Awesome!

I had a talk with TataPlay support and they told me people don’t require Non-Temporary addresses to access internet.
 
Lolita_Magnum

Lolita_Magnum

🦜
Messages
1,132
Location
Mumbai
ISP
Airtel-9892
Jio-55836
SlashN-208959
Hz-24940
Yes, DHCP-PD (Prefix Delegation) is not really native IPV6 since the router is not the one giving out IP addresses, but there are no performance penalty nor public connectivity issues because of this.
Judging by your config on the screenshot above, your router should still be accessible from outside.
 
tatyasky

tatyasky

Messages
416
Location
Mumbai
ISP
TataPlay & Jio
No it is not accessible. Even Asus engineer tried accessing but failed because router itself doesn’t have WAN IPv6 address. It however does have LAN IPv6 which is accessible only from LAN. Adding that IP to IPv6 firewall doesn’t help either.
 
Lolita_Magnum

Lolita_Magnum

🦜
Messages
1,132
Location
Mumbai
ISP
Airtel-9892
Jio-55836
SlashN-208959
Hz-24940
Are your devices accessible from outside via IPV6?
 


T

TheCoolDean

Messages
72
Location
Bangalore
ISP
ACT
sorry if off-topic but when I go to IPv6-test.com I get hostname servfail error, any idea how to fix it? My score is 18/20.
 
Lolita_Magnum

Lolita_Magnum

🦜
Messages
1,132
Location
Mumbai
ISP
Airtel-9892
Jio-55836
SlashN-208959
Hz-24940
@TheCoolDean nothing to be worried about, it just means your ISP does not have Reverse DNS entry for your IP.
 
igloo

igloo

Not just Internet.
Messages
4,263
Location
New Delhi
ISP
Airtel Fiber
Hathway Docsis
From my airtel connection on TP-Link router i can conclude wan ip of router is completely diff from lan prefix of devices and both having /64 prefix.
I guess tata is trying to be oversmart or over conservative(whichever way you like) by saving from every customer /64 wan ipv6 address aka 2^64 /128 addresses i.e. 18,446,744,073,709,551,616 unique ipv6 addresses. :LOL:
 
P

panks21

Messages
213
Location
Delhi
ISP
Airtel Static IP
@tatasky
On Airtel connection I tested few weeks ago. I got WAN IPv6 (non-temporary) on Edgerouter but when I connected Asus ZenWifi AX Mini, I dont get a WAN IPv6 address (sorry no screenshot). Edgerouter Config was shared in the thread below. It is quite possible different implemenation in software in Asus

 
tatyasky

tatyasky

Messages
416
Location
Mumbai
ISP
TataPlay & Jio
I don’t think it’s Asus router issue as most other ISPs are getting WAN IPv6 correctly on Asus routers around the world. TataPlay themselves told me Non-Temporary address are not required by customers. Then they are falsely advertising static IPv6.
 
P

pillaicha

Messages
1,017
Location
India
ISP
Airtel | Jio | V! | BSNL
TataPlay does not support Dual ipv6 prefix assignment, which is required by Asus routers. Asus routers need one prefix for their WAN and another prefix for their LAN side. It is configured on the DHCPv6 server of the ISP to offer only a single prefix to each PPPOE session of a customer. Router must be able to use a single prefix when assigned and configure a globally routable WAN ipv6 from it.

It's a software limitation in Asus that must be fixed by them.
 
P

pillaicha

Messages
1,017
Location
India
ISP
Airtel | Jio | V! | BSNL
To better explain the process of IPv6 address assignment, you may read this.
In some networks, you do not need to assign a global IPv6 address on the CPE WAN link. Your decision depends on the type of CPE being used:

  • If the CPE is purchased by the subscriber, and is not a device specifically recommended by the service provider, you need to assign a global IPv6 address that can be routed on the Internet.
  • If the CPE is supplied by or recommended by the service provider, you can use the loopback interface to manage the CPE.
    In this case, you can use a link-local address or you can use an address that is derived from DHCPv6 prefix delegation.

As far as the solution to your problem is concerned, you may simply setup a RPi to act as a proxy from within your network. Install a DDNS daemon on it, and maybe use a password-enabled self-signed certificate protected HTTPS session which is reverse-proxied via your Rpi to access your router remotely.
 
tatyasky

tatyasky

Messages
416
Location
Mumbai
ISP
TataPlay & Jio
Thanks @pillaicha

But I don't have RPI. I only have QNAP NAS and currently I am using Tailscale to access my Asus Router from WAN. But it's slow and hacky. I also have to keep Tailscale app running in the background which saps battery from my iPhone.