Spectra "Gigabit" is now Half a gigabit

  • Thread starter The_PC_Guy
  • Start date
  • Replies: Replies 3
  • Views: Views 3,598
The_PC_Guy

The_PC_Guy

Messages
185
Location
NA
ISP
Spectra
So. I've been documenting my experience with spectra here.

And for almost a year now spectra is soft capping us at 500mbps instead of full gigabit for any server that's not the closest spectra node.
That too only when it works for most part the speeds dip to 20-30 mbps until the NAT IP assigned by them changes only then the speeds come backup to 500mbps and again after few hours back to 20-30 mbps and this cycle repeats.

After numerous complaints hours on phone talking to their L3 team, complaining on twitter I've gotten nowhere. The speeds dipping to 20-30 mbps is not often as it used to be but it still exists.

I even was building a tool to monitor speeds regularly but gave up due to how pathetic their network was compared to before.

Since I Live in Bangalore the only server I can get speeds my plan promises to is just one server bangalorespeedtest.spectra.co.prod.hosts.ooklaserver.net the rest are at max capped at 500 mbps.

MTR for local spectra speedtest node
Code:
Keys:  Help   Display mode   Restart statistics   Order of fields   quit                                    
                                                                    Packets               Pings             
 Host                                                             Loss%   Snt   Last   Avg  Best  Wrst StDev
 1. 192.168.1.1                                                    0.0%     5    1.0   0.9   0.8   1.0   0.0
 2. 10.201.137.1                                                   0.0%     5    1.5   1.5   1.4   1.6   0.0
 3. 203.92.63.5.reverse.spectranet.in                              0.0%     5    1.6   1.6   1.6   1.8   0.0
 4. 172.19.5.5                                                     0.0%     5    1.6   1.9   1.6   2.5   0.0
 5. 203.92.63.181.reverse.spectranet.in                            0.0%     5    1.7   4.5   1.7  15.2   5.9
 6. bangalorespeedtest.spectra.co                                  0.0%     4    1.6   1.6   1.5   1.7   0.0

the best case scenario that's not a Bangalore spectra server would be their Chennai server
Code:
Keys:  Help   Display mode   Restart statistics   Order of fields   quit                                    
                                                                    Packets               Pings             
 Host                                                             Loss%   Snt   Last   Avg  Best  Wrst StDev
 1. 192.168.1.1                                                    0.0%     9    0.8   0.8   0.7   1.0   0.0
 2. 10.201.137.1                                                   0.0%     9    1.4   1.6   1.4   1.8   0.0
 3. 203.92.63.5.reverse.spectranet.in                              0.0%     9    1.9   1.7   1.5   2.1   0.0
 4. 172.19.5.5                                                     0.0%     9    2.1   1.9   1.6   2.5   0.0
 5. 203.92.63.158.reverse.spectranet.in                            0.0%     8    8.9  11.6   8.9  28.3   6.7
 6. 119.82.112.38.reverse.spectranet.in                            0.0%     8    9.1   9.1   8.6  11.2   0.7
which gives me 480 down and 300up.


I'm curious to see if this is just my region or if its the same with every spectra user. If anyone still has spectra gigabit could you guys run some tests to your local node and some other servers?

I see no point in paying for gigabit when i get these speeds as soon as my current payment period ends i'll either downgrade or switch to a different provider entirely probably.
 
The_PC_Guy

The_PC_Guy

Messages
185
Location
NA
ISP
Spectra
www-speedtest-net-results.png
 
Lolita_Magnum

Lolita_Magnum

🦜
Messages
1,353
Location
Mumbai
ISP
ARTL-24560
VIL-55410
SLN-208959
HTZ-24940
I have had the same issue with Hathway a long time ago, while calling customer care the only result they cared about was speedtest .net (to closest server) results and for everything else they blamed that it was an issue with providers server.
In my old office, we used to have Spectranet, Mumbai location which suffered from the same issue, after a lot of vis a vis their final solution was to provide us with a static public ip, and surprisingly that improved speeds. I don't know how and i don't know why but that just did.
 
Last edited:
The_PC_Guy

The_PC_Guy

Messages
185
Location
NA
ISP
Spectra
it has been over a year and finally something changed. ping and random packet loss seems to have gotten worse than before for most servers.
But on google's regional servers I seem to be getting ~900 mbps UP/DOWN. I've seen few international servers cross 700 mbps for upload too. Will test how it performs in detail when I get the time. Routing to India / Singapore seems to have gotten significantly worse though but it depends on the ASN.

eg:
Singapore
Linode: 190 ms
DigitalOcean: 80 ms
aws" 80-300ms

Mumbai:
Aws: 60ms
Linode: 30 ms

BLR:
Digital Ocean: 30 ms

At least it doesn't seem like all outgoing traffic from the local node doesn't seem to be hard capped at 500mbps now.