Resolving problems with Airtel VoWiFi, WiFi Calling

Disclaimer - this is one possible solution, for a specific scenario. This post does not aim to resolve all possible WiFi Calling issues.
Posting this here for people who have been trying to resolve issues with WiFi calling not working on Airtel, it took me a really long while to figure this out.

Problem: Handset is configured correctly for WiFi Calling, have Airtel v-fiber/xtream broadband at home. Handset does not show the VoWiFi icon at home, but shows the icon when I visit a friend. ViWiFi does not work over my own Airtel home broadband, but works with someone else's Airtel broadband.
Solution TL;DR: Check router DNS settings

Details:
VoWiFi was launched and I was could enable the settiing on my iPhone 7, however the VoWiFi indication (network name changes to AirTel WiFi on an iPhone) never showed up on my mobile handset. In the interim, i visited a friend who has AirTel broadband too, and on connecting to his home internet, VoWiFi showed up as active. Did my research online, found that my home router might not be allowing traffic on UDP ports 4500 and port 500. Experimented with my router, set up port forwarding rules, and still couldnt get WiFi calling to work. Called Airtel moble customer care and Airtel broadband customer care, got passed from department to department with no luck, spent several minutes on multiple occasions with customer care and got fed up. Was told by customer care executives that there is no option on their CRM software to register complaints for WiFi calling, they remotely checked my router and found everything to be set up correctly too.

The Solution:
Randomly while browsing forums where people reported such issues with T-Mobile and Verizon, I chanced upon a post which set my head ticking. I remember having changed the DNS servers configured on the home router a few years ago. I had changed the primary and secondary DNS servers from the default Airtel provided DNS server addresses to Google DNS (8.8.8.8, 8.8.4.4). I called up customer care, got Airtel's primary and secondary DNS server addresses for vFiber in New Delhi (202.56.215.54, 202.56.215.55) restarted my router, disabled and re-enabled Wifi calling on my mobile phone and restarted that too for good measure..
.... and voila VoWiFi!!

I guess for this particular scenario, the issue would be automatically resolved when Airtel opens up WiFi calling to other ISPs because apparently as of now in my area only their own DNS servers are able to look up the Wifi Calling servers. Hope this post helps someone else too.
 

Smh

Messages
2,408
Location
Delhi
ISP
Wired local
for me vowifi works even with VPN on so could be your device or local airtel network issue. With vowifi on it switches to 2g and won't switch to 4g automatically if I go outside of wifi range.
 
Messages
1
Location
Bangalore
ISP
No
I am an Airtel postpaid user in Bangalore.
VoWifi calling is working fine in Jiofi device (dongle) wifi and VoWifi calling does not work when i Connect wifi with Jiofiber (either 2.4ghz or 5 ghz)
Please help
 
Messages
53
Location
Chennai
ISP
ACT x 3, Hathway x 2
Can someone help me with setting up the router for Jio & Airtel VoWifi in ACT connection? For me, calls made through 12 Pro are failing randomly when connected to VoWifi. Others in the house have issues with Airtel VoWifi call quality.
 
Messages
1
Location
Hyderabad
ISP
Act
Try using select and quote feature instead of quoting whole post unless absolutely necessary
Strange issue!! o_O I have iPhone 11 pro with Airtel 4g sim in Karnataka circle, I have been using wifi calling happily, however, suddenly from last month, I observe this - When I restart or flip my phone from airplane mode, Airtel wifi shows up for around 30 secs and then it switches back to Airtel and loses the wifi calling. Did anyone face a similar issue? Any help appreciated.

I am using ACT broadband and there has been no change as such in internet connection from my side.
Trying with another JIO sim on the same ACT wifi works seamlessly on the same iPhone.

I see that there are datapath entries in my router on port 4500 and destination as 106.200.64.1 which seems to match as per @rajil.s post above.
Also tried using different DNS such as Google, OpenDNS, Cloudflare, and ACT native DNS, all give the same result.

P.S> As usual airtel cust care is clueless and asks me to change SIM or turn the option in settings, which both are fine and to even make sure, I replaced my SIM and the issue has been there even after that. :rolleyes:

Hi Parshad,

Did u find any solution for Airtel wifi issue.

Thank You
 
Messages
1
Location
Bangalore
ISP
BSNL
Did you try setting up your phone cell network to 3g instead of LTE?

Once i did that vowifi became 100% stable. Once i step outside the house i change back to LTE.
For me it was working fine till now but, then suddenly i stop seeing the WiFi icon whereas at the same time it was working fine on my android phone connected to same wifi and using airtel sim. I use airtel postpaid sim and BSNL FTTH broadband on iPhone 8. I tried changing the DNS server but that did not work for me. Then, i just switched my mobile network from 3g to LTE and then again to 3g now i can see the WiFi icon on top.
Ps: I see different solutions worked for different people. And, I am on Airtel ₹899 postpaid plan.