Problem installing Seimens C2110 modem drivers

  • Thread starter harrypotterfan999
  • Start date
  • Replies: Replies 18
  • Views: Views 9,066


BSNL 750UL+ & 500C+
@essbebeI don't think can read his name and designation in the screenshots i have uploaded in the thread regarding multi user configuration of the [email protected] people get confused or helpless they post everywhere to seek solution.what's the problem in that? after all he is not expected to know who can help him properly.As in my case I sought suggestion at few places regarding upgrading my desktop pc and buying a new laptop.None answered me properly.Even I didn't get any answer from few so-called hardware gurus after PMing them. So what am I expected to do?Anyway is there any hardware guru (no offence) in this forum to help me?


BSNL Home 500
[*]Sorry for the late reply, but the topic was closed for some time....


Mac writes "Well the drivers should be from Siemens and not BSNL."
Actually the CD provided by BSNL containing the drivers had Siemens' logo. So I presume I can't go wrong with it.


Off-topic: {{
Mac writes "b/w I'm also a HP Fan."
Check out HPANA - Harry Potter News and Rumors - Book 7, Movie 6 and More and join the discussions if you love indulging in Potter debates and discussions. (I amn't spamming, just referring one of my favorite sites). }}


Demigod writes
"Try this steps.
1.unplug your modem usb cable
2.install the software/driver given by BSNL( probably you won't get that error )
3.plug your usb cable and switch on the modem.
your new hardware will be detected and OS will automatically install driver from the software you installed.
tell us the result."

I had tried that before unsuccessfully. After 'Preparing for installation', as soon as it gave the message 'Installing drivers', it showed a message asking me to plug in the hardware (sorry, I don't remember the exact message). So it was just installation as usual, ending in the same error message.

Essbebe wrote:
"No idea USB drivers or FW update. Please check.
link-removed: 1-Click Webhosting >> Discussion Forum >> BSNL Dataone >> BSNL DataOne: Hardware >> Firmware update for SIEMENS C2110"

Tried out these drivers, yielded the same error. And the other discussion's posts showed a lot of dissatisfaction among the people who had used the firmware. Btw, thanks for your efforts.

"Usually in spite of Windows warning/s some drivers of USB etc continue to work. The reply , even though , annoying to you, may be of interest to other members. Not all are 'pro' here."

OK, I'm sorry about being a bit harsh. Actually I'm in need of a really quick solution. My hard drive has only 210 MB free space left. I won't be able to download anything big, unless I clear up my hard drive.

"[email protected]
Give full details of your problem. "

Thanks! I will try today itself.

"Please click the tag c2110 for previous threads on same problem of USB drivers for your modem."

Checked them out. None of those topics have got good response from the forum members- both in terms of quality and quantity (I mean, in terms of relating to my problem).


Mac writes "Well USB drivers not being signed by Microsoft is no indication that one should not try them. It just gives no guarantee of it working thats all.
So try them on your own risk.


I don't think anybody is at risk from BSNL's modem drivers at any cost.

Whitestar_999 writes:
"he is doing something different from the exact steps given in manual on the cd.i already send him the exact procedure at another site where he has a similar query."

I saw your reply at that site (hope mentioning it is allowed in this forum).

"first of all go to device manager & remove/uninstall any driver related to c2110.then after restarting computer connect modem to usb port.if you get new hardware found message click on nothing.insert CD & double click on setup.exe in G:\driver\ where G is your cd next until you get to screen where it asks if you want to NO.after that restart your nothing on the new hardware found window if it is still there."

What do you mean by 'related to c2110'? There's no search feature in Device Manager. So couldn't pin-point anything but I uninstalled whatever drivers were there for the USB port that I use for my modem in the other XP (I have got dual-booting). Then again the same process and the same error (I really am growing sick of seeing that error). Please help!


Mac writes "you mean he asked this same question on another site.this same guy.LOL"

Actually I have posted the same thing in 3 different sites for quicker responses but still no success. You would do the same when you become desperate for an answer.

Whitestar_999 writes "i know many users who have asked the same question at different forums/sites including here.after all the more places you ask the greater will be the probability of finding the answer within lesser time period."
Mrbgupta writes "when people get confused or helpless they post everywhere to seek solution.what's the problem in that? after all he is not expected to know who can help him properly."

Couldn't agree more.


Mrbgupta writes:
"Here is firmwire upgrade file:"

After reading negative reviews (slowdown of connection) of the firmware, I decided against doing anything with it.

Actually what astonishes me is that the BSNL guy used the same CD, didn't tweak any Device Manager settings (or any advanced settings at all), didn't touch the cables (I had told him that another fellow from BSNL had done that job earlier) and apparently did what I had done earlier and yet he got the job done in one go, while here I am frustrated after more than 30 failed attempts.

I once had used an April Fool's Day mini software that after being started, popped up an insulting message every few minutes on the screen. The only way to close it was to right click at a certain spot of a small picture in the dialog boxes. This BSNL drivers remind me of that…it is seriously making me have second thoughts if there's any such small secret step that I'm ignorant of.

If it were some problem with my XP, then it should have worked fine on the newer XP (which I had to install specifically for checking out this driver installation). Please help!!!



here is the exact CD files which worked for me.its just a guess but it may be possible that your driver setup files are corrupted(scratch on CD etc).no harm in trying this too.---
link-removed: 1-Click Webhosting

PS--sometimes error 691 happens to me too but it usually get away after restarting the modem.


I myself had installed the modem thru usb port and also configured it using the lan port no problems. I'm using winxp sp2.

please check this site for further info