Port Forwarding on Airtel with 2 NAT devices

Messages
6
Location
NA
I have a Beetel 220BX modem(provided by Airtel) and a Linksys WRT 54GH(Mine).I have been trying to port forward so I may accept incoming connections from the port 25565.This is required for hosting a server for a game called Minecraft. The server application runs on a host system and all it requires is an open port for connections.I set it up so the incoming connections on port 25565 on the modem are routed to port 25565 on my router, and from there to port 25565 on my computer.I understand that there are two ways of forwarding ports when I have two NAT devices. One such way is setting my modem to bridge mode and forwarding only on the router, or forwarding on both of the devices.I would show you screenshots of my settings, but I'm not at home right now, and won't be till Monday.I plan on using a service such as no-ip.org instead of getting a static IP from Airtel. My computer's IP on the local network is static.Basically, I am noob. Halp pl0x?
 

x720

Incoherent Poster
Messages
10,414
Location
Gurgaon | Mumbai
ISP
airtel, BSNL, MTNL
Using bridge mode on the 220BX is the way to go.! . Easier too
 
Messages
6
Location
NA
Using bridge mode on the 220BX is the way to go.! . Easier too

I called Airtel and their tech support dudes helped me to set the modem to bridge mode. This was a few months ago, and since then I have switched back to PPPoE. For some reason, in bridge mode, every time I disconnected the cable, I would have to do a whole bunch of random things to get it to work again. What is up with that?

Anyway, I have no clue how to switch to bridge mode on my own. I could use some help with that.
As soon as I get back home on Monday, I will post screenies of my settings.
 

x720

Incoherent Poster
Messages
10,414
Location
Gurgaon | Mumbai
ISP
airtel, BSNL, MTNL
Lets do this from scratch.

1. The 220BX is set to bridge mode. Forget about this device now.
2. The 220BX is connected to your wifi router. You log in to your wifi router. Enter username pw, and save, your net starts working.
3. You now need to set static IPs on the devices you would be using to access minecraft. Once, IPs have been set to static, you need to forward ports on your wifi router to these devices. This can be done using this -
http://portforward.com/english/routers/port_forwarding/Linksys/WRT54GH/Minecraft_Server.htma
4. If you follow all steps correctly, I see no reason as to why the ports should appear as closed ;)
5. Open Port Check Tool - open port checker
 
Messages
6
Location
NA
I have used some weird tool called pfstatic IP by the people at portforward.com to make my ip static. I set my server's local ip to 192.168.0.50. I have already posted my port forwarding page above. I'm quite sure that the ports are forwarded correctly. That is why I posted here in the first place. I can't seem to figure out what is wrong. Maybe the tool to mage threw ip static didn't work. I will make it static manually.