OpenWrt Router setup for Tikona and other Wireless Internet Service Providers?

i0s

Member
Messages
9
Location
Opp. Phoenix Marketcity
Hi guys,

I'm trying to setup OpenWrt with Tikona broadband and so far had tried few things with no success. I hope someone here might have got it working. If so could you please guide me generic steps to do under OpenWrt 15.05.1 using Luci web interface/command line.

If you guys need more info about the router and issues I'm facing you can read the ongoing topic which I posted on openwrt forums. Please find the link below and let me know your thoughts.

Confused with OpenWrt Router setup with WISP please any one help me! (Page 1) — General Discussion — OpenWrt

Above all I know using Tikona and expecting much to do with OpenWrt is never a good idea. But TBH knowing about Indian telcos and me being stupid got my time wasted after trying all the options. To find out how I ended up with Tikona you can read my full story in the introduction post at the link below. I wrote the topic in frustration and usually hate writing long posts so please pardon my grammar. But very soon I might find alternatives or even relocate to some where I can have reliable 5-10Mbps connection or even more.

Do Bangalore really sucks in terms of providing reliable home broadband with 90% uptime?

PS: I came to know @vedantlath is right person to deal with openwrt issues and been in touch with him and in fact he was one of them along with @Ouch who told me to post my question here.
-----------------------------------------------------------------------------------------------------------------------------------
Guys issue has been resolved now and for solution you can visit the OpenWrt link above. If you've any doubts please post them here and some one will look and reply back.

:) :clap:Special thanks to @vedantlath who had taken his time and effort to investigate the issue and to resolve it.
 
Last edited:

vedantlath

Member
Messages
101
Please post the output of the following commands in the OpenWRT telnet/ssh shell:
# ip -details link show
# ip address show
# swconfig list
# swconfig dev switch0 help
# swconfig dev switch0 show
# cat /etc/config/network

Also post the output of "dmesg" and "logread" in a pastebin.
 

i0s

Member
Messages
9
Location
Opp. Phoenix Marketcity
@vedantlath

Thanks for your quick reply. I've got the outputs and tried to use pastebin but unfortunately I couldn't open the website due to being blocked by the ISP. Strange but real !. However I've used alternative called pasted.co please find the links below and let me know If you have any problems opening the links.

# ip -details link show
# ip address show
# swconfig list
# swconfig dev switch0 help
# swconfig dev switch0 show
root@OpenWrt:~# ip -details link show -ash: ip: not found root@OpenWrt:~#... - 40ce5d63

# cat /etc/config/network
Network Config - 72f442e2

Also post the output of "dmesg" and "logread" in a pastebin.
dmesg - 3ce10542
root@OpenWrt:~# logread Tue Mar 1 09:03:44 2016 kern.debug kernel: [ 0.332000]... - f9fcedad
 


vedantlath

Member
Messages
101
Also paste the output of:
# ifconfig -a

Go to OpenWRT router page -> Network menu -> Switch, then take a screenshot of the page and post it here.
 

vedantlath

Member
Messages
101
I have made some changes to your /etc/config/network file here: RE:#72f442e2 - 10241d9c

Try changing your network file and see if it works. You will also need to change /etc/config/firewall and replace WAN with wan. You can use vim to make these changes.

I guess your router does not have a separate wan port so I have made port 0 as the wan port. You will need to plug the WISP's LAN cable into either port 1 or port 4 of your router and see which one works.
 

i0s

Member
Messages
9
Location
Opp. Phoenix Marketcity
@vedantlath I've tried the changes but unfortunately it didn't work. First re-flashed the image then applied the changes and rebooted via command line. After the reboot I couldn't login via SSH or webUI, tried all ports. All I get is error saying connection refused/operation timeout.
 

i0s

Member
Messages
9
Location
Opp. Phoenix Marketcity
@vedantlath If you're comfortable on OpenWrt forum then from now on we can shift the conversation over there. And later on once the issue is resolved then I can do a write up and put it here. Let me know your thoughts also I've just replied on OpenWrt forum please check.
 

Top