MTNL TriBand Mumbai - does it block incoming ssh connections?

knura

Newbie
Messages
56
Location
NA
ISP
MTNL TriBand 320Kbps UL, Tata Indicom 1Mbps UL
I wish to give my software development team, access to a server on my LAN over ssh (secure shell) connections coming in from the Internet.I have setup an "Incoming Filter" in my ADSL router to forward *all* incoming connections on port 30303 to the LAN server on 192.168.90.2 port 22.Yet when my developers try to connect using "ssh -p 30303 @," they get an immediate "Connection refused."This is unexpected behaviour since I have set the port forwarding rule in the ADSL router. I have been able to do this in the past (about two-three years ago).FWIW, there are no firewall rules on the LAN server.I suspect that either my ADSL modem is flaky or MTNL is blocking such connections with some kind of L7 filters.Has anyone else experienced blocking of incoming connections to ssh?
 

amish

Star gazer
I got banned!
Messages
24,768
Location
Mumbai
ISP
MTNL Mumbai BB_600 @12mbps
I use SSH many a times to connect to my PC..never faced any issue. it must be some wrong setting at ur end.
 

knura

Newbie
Messages
56
Location
NA
ISP
MTNL TriBand 320Kbps UL, Tata Indicom 1Mbps UL
Thanks for your response. It kind of confirms my suspicion that the problem is most likely in my ADSL modem/router. Time to make a trip to the tel. exchange for a replacement.
 

amish

Star gazer
I got banned!
Messages
24,768
Location
Mumbai
ISP
MTNL Mumbai BB_600 @12mbps
It may not be router problem at all. It looks more like ur settings.Try with bridged mode.
 

knura

Newbie
Messages
56
Location
NA
ISP
MTNL TriBand 320Kbps UL, Tata Indicom 1Mbps UL
Thanks for your suggestions re: bridged mode. I prefer to not to use "bridged" mode and "forward" only specific ports (services).I am pretty sure that the MTNL supplied modem/router is on the way to RIP. Today, I have not been able to enter specific ports in the incoming "source" and "destination" ports under the Advanced>Filters tab. Nothing happens when I click on the drop down menu. I have power cycled it a few times but no avail.Fortunately, I also have Tata DSL service. I have added the port forward rules in the Tata dsl router and users are able to ssh into the server.I will report the progress, once I get the MTNL modem replaced and the setup done.