Made the Jump from 1gbps Spectra to 300mbps Airtel XStream

Edit: Bridge mode is now working, so I have a public IP on my personal router‘s WAN port now.

I was facing issues with Spectra for quite some time, so decided to change back to Airtel XStream (I had Spectra for around 1 year and Airtel Fiber 300mbps before that). A short timeline

1. Raised request via Airtel app : 11:00
2. Got call from Airtel Sales for document verification : 11:11
3. Got visit from Airtel Sales for document verification : 12:00
4. Got visit from Airtel Technician for GPON/Router installation : 13:00
5. Connection up and running : 13:20

Basically, Airtel has streamlined the entire process. The GPON and the router are now in a single box, which is good news for people who want less clutter, but bad news for people like me who like to use their own router (Moe details about this ahead).

Once the router is connected to the fiber (My house had airtel fiber already, the technician just cut off a bit of fiber and spliced it again) and powered ON, I automatically received a message with the wireless name on the router and password. It looked like the router was provisioned remotely automatically with my account details. Once I visited a link in that same message, I was given an option the chane my Wifi name and password, which again were pushed to the router remotely and setup was done.

However, this was against my wishes of having the public IP on my Netgear Nighthawk router and I didn't want to do double NAT, so

1. I tried configuring the ONT into bridge mode. It doesn't allow that. So the public IP and PPPoE will always be on the ONT
2. I tried configuring my router (R7000) in AP mode, but that disabled guest WiFi which I use
3. I sucked up and configured 2 private networks. One between the ONT LAN and my router WAN and one on my Router's LAN, but this means double NAT
4. I put my Router's WAN IP in DMZ of the ONT. Looks like port forwarding etc. now works as expected

Finally, I get actual 300mbps speeds (On Spectra, speedtest showed my 1Gbps, fast.com showed me 50mbps and Netflix was always stuttering). Things look good on Airtel now, however, it looks like this GPON is rated up to 300mbps only and if I need to upgrade to 1Gbps in the future, I would have to get them to change the ONT again, which is not ideal.
 
Last edited:
Messages
55
Location
NA
ISP
Spectra
It’s public. Weird, as Airtel has been talking about implementing CG-NAT for years now. Another advantage of moving away from Spectra.

Also, with Airtel I believe you have an option to pay extra for a static IP. 1 year ago it was around 199 if I remember correctly.
 

Attachments (DOWNLOAD AT YOUR OWN RISK)

  • F744A664-9EF6-4C5C-A9C8-9424561DAE95.jpg
    F744A664-9EF6-4C5C-A9C8-9424561DAE95.jpg
    53.8 KB · Views: 95
  • 944E9F3B-91AF-4B30-9E05-2D6135EE9DFC (1).jpg
    944E9F3B-91AF-4B30-9E05-2D6135EE9DFC (1).jpg
    49.9 KB · Views: 90
Last edited by a moderator:
Messages
463
Location
Gurgaon
ISP
BSNL FTTH
@tinoryls Yeah, i figured but was still hoping for a way to access the WAN port without having to disconnect from the main router, as i believe there's always someone better than you with a solution to your problem. For now i have kept the 2.4Ghz wifi on the ONT enabled so that i don't have to fetch the LAN cable every time i want to access my ONT.

Also anyone here can answer this, Is there a way to use the bridged ONT's wifi to serve internet over it?
 
Messages
55
Location
NA
ISP
Spectra
@tinoryls Yeah, i figured but was still hoping for a way to access the WAN port without having to disconnect from the main router, as i believe there's always someone better than you with a solution to your problem. For now i have kept the 2.4Ghz wifi on the ONT enabled so that i don't have to fetch the LAN cable every time i want to access my ONT.

Also anyone here can answer this, Is there a way to use the bridged ONT's wifi to serve internet over it?
The only way you would be able to do that would be if you loop a cable from your personal router’s LAN port to the ONT’s LAN port, but might get complicated. Make sure the LAN port on the ONT you use for this purpose does‘take bind to the PPPoE bridge