Made the Jump from 1gbps Spectra to 300mbps Airtel XStream

Edit: Bridge mode is now working, so I have a public IP on my personal router‘s WAN port now.

I was facing issues with Spectra for quite some time, so decided to change back to Airtel XStream (I had Spectra for around 1 year and Airtel Fiber 300mbps before that). A short timeline

1. Raised request via Airtel app : 11:00
2. Got call from Airtel Sales for document verification : 11:11
3. Got visit from Airtel Sales for document verification : 12:00
4. Got visit from Airtel Technician for GPON/Router installation : 13:00
5. Connection up and running : 13:20

Basically, Airtel has streamlined the entire process. The GPON and the router are now in a single box, which is good news for people who want less clutter, but bad news for people like me who like to use their own router (Moe details about this ahead).

Once the router is connected to the fiber (My house had airtel fiber already, the technician just cut off a bit of fiber and spliced it again) and powered ON, I automatically received a message with the wireless name on the router and password. It looked like the router was provisioned remotely automatically with my account details. Once I visited a link in that same message, I was given an option the chane my Wifi name and password, which again were pushed to the router remotely and setup was done.

However, this was against my wishes of having the public IP on my Netgear Nighthawk router and I didn't want to do double NAT, so

1. I tried configuring the ONT into bridge mode. It doesn't allow that. So the public IP and PPPoE will always be on the ONT
2. I tried configuring my router (R7000) in AP mode, but that disabled guest WiFi which I use
3. I sucked up and configured 2 private networks. One between the ONT LAN and my router WAN and one on my Router's LAN, but this means double NAT
4. I put my Router's WAN IP in DMZ of the ONT. Looks like port forwarding etc. now works as expected

Finally, I get actual 300mbps speeds (On Spectra, speedtest showed my 1Gbps, fast.com showed me 50mbps and Netflix was always stuttering). Things look good on Airtel now, however, it looks like this GPON is rated up to 300mbps only and if I need to upgrade to 1Gbps in the future, I would have to get them to change the ONT again, which is not ideal.
 
Last edited:
Messages
463
Location
Gurgaon
ISP
BSNL FTTH
This is my wan settings for bridge mode. As far as i can remember i never reset my ONT.
LH27gog.png
 
Messages
463
Location
Gurgaon
ISP
BSNL FTTH
I was able to get it in bridge mode. The trick is not to try to edit connection 1 for wan, but delete it and create a new one with bridge type. That does the trick. Everything is now working as expected.
Ah, yes. Now i remember i did actually delete it and create a new Wan profile. It's been ages since i did that. forgot what i actually did. One question, are you able to access the web interface of your ONT via the router on which you setup the WAN profile?
 
Messages
63
Location
Bangkok, Thailand
ISP
TrueOnline, TrueMoveH, Jio
@tinoryls Since you've used both the ONTs.Care to answer #33
I had the old Alcatel Lucent (Not her branded Nokia) ONT. I have used it for up to 1Gbps. It was a simple Layer 2 device. I never logged into it, it was in bridge mode by default and worked fine.
The new Huawei one is a Layer 3 router and needs to be put manually into bridge mode to make it act as pass through. Also has wireless, which I have disabled.
If the guys are talking about some new Nokia ONT, I am not aware of it.
 
Messages
63
Location
Bangkok, Thailand
ISP
TrueOnline, TrueMoveH, Jio
Ah, yes. Now i remember i did actually delete it and create a new Wan profile. It's been ages since i did that. forgot what i actually did. One question are you able to access the web interface of your ONT via the router on which you setup the WAN profile?
No, because once you configure PPPoE, everything goes via the public IP directly into the Internet. The way to access the ONT is to login via one of the spare LAN ports, but I see no reason to do that anymore, as it is doing what it needs to and doesn’t need any more changes.