MTNL (General) Is there a workaround for WiFi reconnection issue in iPhone 6 with 450TC1 modem?

nevillek

Regular
[OP]
Regulars
Feb 15, 2011
176
0
Mumbai
Okay, so I had this perfectly fine 450TC1 ADSL2+ modem from MTNL but ever since I purchased the iPhone 6, I noticed a weird problem on the phone.

Every time the phone comes back on from sleep, it shows connected to the wifi, but no data transfers. So I usually have to manually disconnect and reconnect. This problem never happened on my Sony laptop or phone. But the same problem happened on all my friends' iPhones when they were at my place. I discovered this is a known issue with this modem/Apple products: Tech Query: WiFi reconnection problem in MTNL 450TC1 modem

So MTNL replaced this modem with a Binatone modem, but although it solved the above problem, the modem seems to have made my connection really slow on all devices and I'm sick of complaining to MTNL to check the server line and stuff, so I feel it's the Binatone modem only. And want to replace it back with the 450TC1 modem.

So I want to know if you tech guys know of any app that I can download on the phone to resolve the wifi dropping issue and manually disconnect/reconnect the Wifi for me everytime the phone wakes up from sleep?
 

d5aqoëp

Regulars
Aug 13, 2014
1,080
406
@nevillek
It might be iOS problem caused by the process called Discoveryd. It was introduced in iOS 8.0 and existed till 8.4.1. It was so buggy and problematic that Apple has finally reverted back to earlier mDNSresponder from iOS 9.0 onwards.

  • First make sure you are updated to iOS 9.0.2 as off today.
  • Secondly, reset your iPhone's network settings after you update to 9.0.2. Go to Settings -> General -> Reset -> Reset Network Settings -> Enter your passcode.
  • Thirdly, fully reset your modem and set it up again including wifi name and password.
This should fix all the wifi issues.

If you still have the problem, get a TP-Link ADSL + Wifi modem cum router.
 
  • Like
Reactions: nevillek

nevillek

Regular
[OP]
Regulars
Feb 15, 2011
176
0
Mumbai
@nevillek
It might be iOS problem caused by the process called Discoveryd. It was introduced in iOS 8.0 and existed till 8.4.1. It was so buggy and problematic that Apple has finally reverted back to earlier mDNSresponder from iOS 9.0 onwards.

  • First make sure you are updated to iOS 9.0.2 as off today.
  • Secondly, reset your iPhone's network settings after you update to 9.0.2. Go to Settings -> General -> Reset -> Reset Network Settings -> Enter your passcode.
  • Thirdly, fully reset your modem and set it up again including wifi name and password.
This should fix all the wifi issues.

If you still have the problem, get a TP-Link ADSL + Wifi modem cum router.
I have 9.0.2 and tried resetting the phone's network settings. Do you think its possibly a security setting of the router? Is there an app that will keep wifi alive instead of buying a new modem?
 


d5aqoëp

Regulars
Aug 13, 2014
1,080
406
^^ No app will help you.

Reset you router. Would it be possible to fully reset your iPhone and set it up as new? Back up your photos and what's app chats then reset it.
 
  • Like
Reactions: nevillek

nevillek

Regular
[OP]
Regulars
Feb 15, 2011
176
0
Mumbai
I can but if this problem is happening on all iPhones (not just mine) and only on this modem brand, I don't see how this would be of any help.
 

amish

Star gazer
Regulars
Jul 3, 2006
24,750
1,080
Mumbai
Its a known issue that iPhone 6 (iOS 8) does not work well with some routers.

Apple messed up big time and did not bother to acknowledge the issue.

Earlier I had MTNL provided WiFi router and it did not work.

I bought Netgear D500 and it works well now. (even with iOS 8)

As people said above upgrading to 9.0.2 may also fix the issue.

I had 2-3 android phones also working. There are still some drops at times but overall manageable.
 


  • Like
Reactions: nevillek

nevillek

Regular
[OP]
Regulars
Feb 15, 2011
176
0
Mumbai
Its a known issue that iPhone 6 (iOS 8) does not work well with some routers.
My cousins have iPhone 4 and 5, and they experienced the same problem at my place with the 450TC1 modem. But after replacing it with Binatone, that issue was resolved.

Also, I have iOS 9.0.2 only.

I really want some kind of workaround with the 450TC1 modem since I feel some setting needs to be tweaked.
 

Similar threads