Huawei EchoLife GPON HG8546 ONT - Not able to login

#1
Hello friends..

I am not able to login to my ONT. Its Huawei Gpon ONU HG8546M. I just need to understand how can I login.

Background - I stay in Pune and I had opted for the FTTH from BSNL. Our builder has appointed a thirdparty vendor to get the fiberoptic connection and FTTH setup done. He was providing the ONT at 4k. I was able to procure it for 2.5k so I went ahead and procured the exact same model that was being prvided by the vendor. I also opted for BSNL as my ISP.

Coming back to my problem -

1) The vendor was able to login earlier with telecomadmin/admintelecom details and did some configuration.
2) Then the vendor did a factory reset to restore the factory settings as he was not able to connect to the internet.
3) Now we see the login page with HUAWEI logo and HG8546M written on IP 192.168.1.1 but we are not able to login with telecomadmin/admintelecom or any other possible combination. It says "Incorrect account/password combination". I tried 40-50 combinations that I could find all over the internet (eg - http://setuprouter.com/router/huawei/passwords.htm). I have also tried the hard reset, 30-30-30 reset. Nothing has worked so far.

If you can help me reset the password or try some credentials that will work it will be helpful.
 
#3
root/admin gave me telenet access but not the web intreface access.. can't do much with the telnet/shell access
 


mayank yadav

Member
Regulars
#5
Edit: First try this
Code:
display users [ all ]
try running this command via telnet
Code:
set userpasswd
if this doesn't work then try gaining superuser access by typing
Code:
su
and then try out the above command.
PS : Please dont make duplicate threads. I would suggest you to delete the other thread and merge it into this one.
 
Last edited:
#8
1) Can you guide me how do i connect with ftp? from windows to the ONT or from ONT to the windows. I think I tried it from windows cmd but wasnt able to login by ftp. I know the config file and its location. Its encrypted and hence I will need to get it on windows, decrypt, edit and then put it back. Cant edit in vi there.

2) After logging in with admin/root, I entered 'su' with was successful and then I entered 'shell' to get the linux prompt.

2) Since root/admin is working from telnet but not from web interface, I will like to if there are two different sets of users, one for telnet and one for web. In that case the 'set userpassword' command will work only for telenet users?
 

mayank yadav

Member
Regulars
#9
I don't know the command will work for you or not, you need to try the commands i told you to try and give me the results.
For ftp connect via an ftp client like filezila port number is 23
Also try to run "help" command via telnet. Hopefully it should return a list of commands for your router.
 
#10
Tried a few things.

1) BusyBox shell is present.

Source


2) Didnt find a way to list the web interface users. /etc/passwd showed the list of users for the shell.

Source


3) Display version worked, but nothing worked for users display.

Source


4) 'Help' didnt work. '?' gave list of available commands.

List is uploaded here - Untitled Post

5) I am not yet able to FTP the config file. I have started the ftp feature on my laptop but am not able to connect to it from another laptop in the same network or from the shell. Getting connection refused error.