How to successfully do pppoe ipv6 on openwrt with airtel bb?

  • Thread starter nishantt6969
  • Start date
  • Replies 14
  • Views 905
nishantt6969

nishantt6969

Messages
1,085
Location
Barabanki
ISP
Airtel Xstream Fiber (1Gbps)
Jio Fiber (150Mbps)
When I create wan interface with pppoe protocol it automatically generates a virtual pppoe v6 interface and that interface is not accessible, means I cant change ipv6 dns servers and modify other settings. Anyone who knows about it please help me out.
 
Lolita_Magnum

Lolita_Magnum

🦜
Messages
984
Location
Mumbai
ISP
Airtel-9892
Jio-55836
SlashN-208959
Hz-24940
Hello, @nishantt6969
Make sure the following firewall rules are enabled in your router.
config rule
option target 'ACCEPT'
option src 'wan'
option proto 'udp'
option dest_port '547'
option name 'Allow DHCPv6 (546-to-547)'
option family 'ipv6'
option src_port '546'

config rule
option target 'ACCEPT'
option src 'wan'
option proto 'udp'
option dest_port '546'
option name 'Allow DHCPv6 (547-to-546)'
option family 'ipv6'
option src_port '547'
And, your LAN DHCPv6 is set to relay mode.
You can check this webpage out for more information.
 
sloj

sloj

RIP, Felis Catus
Messages
1,078
Location
Guwahati
ISP
BSNL
You can disable 'Obtain IPv6 address' under advanced settings in the interface for pppoe and create a separate interface for IPv6 wan. Then you will be able to change settings like in v4 interface. And if you do that, you might need the firewall rule @Lolita_Magnum mentioned. Otherwise it's fine. You can also uncheck 'Use DNS servers advertised by peer' under advanced and specify any DNS server you want in dnsmasq or any other DNS server you are using.
 
Last edited:
M

mikrotik

I am getting updated....
Messages
2,922
Location
Noida
ISP
Airtel FTTH
If you are successful, do post the complete steps.
 
D

doineedto

Messages
78
Location
Thane
ISP
Airtel Xstream Fibre
I have been running bridge mode with OpenWRT successfully for a few months now! This is the configuration on a fresh OpenWRT install:
  • Under Advanced settings of WAN, set "Obtain IPv6 address" to manual
  • Create a new interface which is an alias of WAN. It's settings as follows:
    • Protocol: DHCPv6 client
    • Request IPv6 address: Disabled
    • Request IPv6-prefix of length: 64
    • Set firewall zone to WAN
  • For LAN, following are the settings:
    • DHCP Server -> IPv6 settings -> RA Service: Server mode
    • DHCP Server -> IPv6 settings -> DHCPv6 Service: Server mode
  • Firewall settings as given by @Lolita_Magnum
  • Reboot the router. It might take a minute or two to get an IPv6 address. If not, try restarting the interface
This will get you a prefix delegated /64 IPv6 address on the WAN6 interface.
 


M

mikrotik

I am getting updated....
Messages
2,922
Location
Noida
ISP
Airtel FTTH
@doineedto So this thread is about dialing Pppoe for IPv6. This is specially for the static ip users.
 
C

Chip

Messages
864
Location
Pune
ISP
FTTH: Airtel, TPBB, BSNL
LTE: Airtel, Jio, Vi
You do not dial PPPoEv6 with Airtel...you dial a normal PPPoE v4 connection and the router uses that PPPoE v4 to request a v6 address (/64 PD) via RA. This in turn is delegated to other devices on the Airtel router's LAN port or WiFi.
 
Aashish.007

Aashish.007

Messages
323
Location
India
ISP
Airtel XStream Fiber
JioFiber
Jio 4g
Airtel 4g
Also I have already sorted this problem on pm with you so what is the need to create a whole thread.
 
Aashish.007

Aashish.007

Messages
323
Location
India
ISP
Airtel XStream Fiber
JioFiber
Jio 4g
Airtel 4g
Wan6 kis device pe hai?
Make it to @wan, it should be dhcpv6.
All this is easily available on openwrt forums, you just need to read.