How to stop carrier info messages?

  • Thread starter saffronarrow
  • Start date
  • Replies 6
  • Views 8,691
saffronarrow

saffronarrow

Messages
1
Location
Bhopal
ISP
Idea, Vi (Vodafone Idea)
Hi, I just recharged my idea sim after swapping for a new Vi sim. VoLTE wasn't activated by default, but a call to the customer care did the trick. However, when I try to send an SMS, it immediately follows up with a carrier info alert [PFA screenshot], displaying my balance. At this moment, the network fluctuates from 4G to 3G to 2G, and then comes back to 4G after a while. I am using Redmi Note 7 Pro. Any leads as to how to resolve this issue? Thanks in advance.

(P.S. I have deactivated flash messages, disallowed push WAP, as well as activated full DND on my cell)
screenshot.jpg
 
Last edited:
Mikymouse5678

Mikymouse5678

Messages
1
Location
Mohali
ISP
Airtel
Did u got the answer??
 
Upvote 0
I

ishanjain28

Messages
384
Location
UP
ISP
Precious Netcom 100mbps x2 & Airtel LTE Failover
Uninstall the package that sends these messages.

Use adb to get shell access and then run,

Code:
pm uninstall -k --user 0 <package-name>

Check all the packages on your phone. There should be something like, com.android.simtoolkit/com.android.simtoolkit1/com.android.simtoolkit2.

it'll come back after you update the phone and then you have to repeat the process.
 
Upvote 0
W

wheatbread

Messages
386
Location
Bihar
ISP
Railwire
You can disable carrier broadcast messages by send a sms, IDK which for Vi ( Google or CC is your friend) or you can use menu in the STK (SIM toolkit) to disable it. Don't uninstall any simtoolkit package, it's how the carriers configure your phone's carrier settings. This is replaced by Carrier Services by Google in newer android versions where you can do these stuff in your phone settings.
 


Upvote 0
SVK

SVK

svknet.wordpress.com
Messages
11,049
Location
India
ISP
Airtel 4G
Recently I got VI sim with special number. For now I inserted it in Nokia 105 2G handset. This phone is mostly on Silent mode. Still it gives loud beep when some Carrier message arrives. This is not like normal SMS, as it displays Click Ok instead of Reply option when I press Right key.
I have enabled full DND, still this messages have not stopped. I had to Switch off phone for now to stop hearing this beep :D
 
Upvote 0

Similar threads