How to set DNS in ZTE Router???

  • Thread starter soumyadeep.chelsea.bhowal
  • Start date
  • Replies 15
  • Views 2,321
su_mumbai

su_mumbai

Newbie
Messages
28
Location
Mumbai
ISP
Airtel
Yes, even in my ZTE router, if I set a custom DNS (e.g. Cloudflare), it still shows up as Airtel Broadband on DNS Leak Test.

Instead, I just enable the DNS over HTTPS setting in my Firefox/Chrome browser, select Cloudflare and then it shows up as Cloudflare on DNS Leak Test.

It's not a big problem, but it will be nice if someone figures out why the DNS values entered in the ZTE router don't work.
 


Lolita_Magnum

Lolita_Magnum

🦜
Messages
985
Location
Mumbai
ISP
Airtel-9892
Jio-55836
SlashN-208959
Hz-24940
under Local Network tab > LAN > under DHCP Server > untick ISP DNS > add your custom Primary and Secondary DNS > click apply.
Reconnect client devices, you will see your custom DNS working.
 
su_mumbai

su_mumbai

Newbie
Messages
28
Location
Mumbai
ISP
Airtel
Nope. Tried both the options below:

OPTION 1:
Local Network > LAN > DHCP Server >
ISP DNS: Off
Primary DNS: 1.1.1.1
Secondary DNS: 1.0.0.1

OPTION 2:
Local Network > DNS >
IPv4 DNS Server 1: 1.1.1.1
IPv4 DNS Server 1: 1.0.0.1

Both times, ISP shows up as Airtel Broadband instead of Cloudflare on DNS Leak Test.

It's not a big issue for me because I have to enable DNS over HTTPS in the browser anyway to use GoodbyeDPI. I'm just wondering why entering the DNS settings in the router doesn't work.
 
Lolita_Magnum

Lolita_Magnum

🦜
Messages
985
Location
Mumbai
ISP
Airtel-9892
Jio-55836
SlashN-208959
Hz-24940
Screenshot-2022-0424-154822.jpg
No clue, it's working just fine for me. Using the same zte modem/router.
 
Md Faraz

Md Faraz

Messages
140
Location
Patna, Bihar
ISP
Airtel, Vi, Airtel Xstream Fiber
that's IP address not DNS
You can change your DNS from here
Working fine for me also. I'm using NextDNS and in dnsleaktest, it shows next dns on my all connected devices.
 
Lolita_Magnum

Lolita_Magnum

🦜
Messages
985
Location
Mumbai
ISP
Airtel-9892
Jio-55836
SlashN-208959
Hz-24940
It seems if you have a working ipv6 connection, then dns address on dnsleak shows up as Airtel broadband. Disabling ipv6 rectifies the issue.

I don't know why it happens, there's no settings in the router to set custom ipv6 dns.
 
A

Ashbro

Messages
20
Location
Gurgaon
ISP
Airtel XStream
I am using a pihole as my dns server, with resolvers set to Quad9.
Pihole query logs show all dns requests being served by Quad9 only.

But dnsleak tests shows Airtel IP, not sure how they are determining my DNS provider , I think it's simply showing my public IP.
and I know for a fact that quad9 is being used as my dns provider, I have checked and verified.

Maybe these DNS leak test sites are not reliable?
 
A

Ashbro

Messages
20
Location
Gurgaon
ISP
Airtel XStream
It seems if you have a working ipv6 connection, then dns address on dnsleak shows up as Airtel broadband. Disabling ipv6 rectifies the issue.

I don't know why it happens, there's no settings in the router to set custom ipv6 dns.
There's actually a setting in the router to set custom DNS for IPv6, it took me also long time to spot this one.
Login to router page, go to local network -> LAN -> then sleect IPv6.

This screenshot might help: