[Guide] How to host webservers on Jio Fiber, accessible to IPv4 clients

As you might know, Jio does not offer static IPv4, and it is not easy to apply for port forwarding (for Camera etc. purposes). However, they do provide IPv6 and this can be used for hosting web servers.

To allow IPv6 incoming connections to your device (e.g. a PC running nginx), you need to disable all firewall rules in Jio Router. (At least initially for ease of setup / troubleshooting - once you get it working you can slowly tighten it up).

Your device on which you want to host must be connected to your Jio router directly (Wifi or LAN) and must have IPv6 assigned from the Jio router's DHCP.
On your device running webserver (nginx, plex, whatever), make sure it is bound to localhost or the IPv6 equivalent (NOT 127.0.0.1 - this wont allow IPv6 connectivity). Usually apps bind to all network interfaces so you should be fine.

From command prompt (or equivalent), Type ipconfig all (if you're on linux you probably know the commands - but it should be ifconfig), and view your IPv6 address. This is indeed your "Public IPv6". Let us assume it is 2001:0db8:85a3:0000:0000:8a2e:0370:7334

If your server is running on port 80, for example, you can now, from another client, access it by specifying a URL [2001:0db8:85a3:0000:0000:8a2e:0370:7334]:80. But this is limited to IPv6 clients only.

For IPv4, you need a domain name. Freenom offers free '.tk', but I'd recommend spend $1 and get a .xyz or something from namecheap. With a domain name, you can setup a cloudflare website, and have the DNS AAAA record point to your IPv6 (no A record).

E.g. AAAA record for 'randomdomain.xyz' -> 2001:0db8:85a3:0000:0000:8a2e:0370:7334

Set cloudflare proxy for the domain to "On". Now cloudflare will act as an automatic gateway, and IPv4 only clients can go to randomdomain.xyz, and access cloudflare over IPv4, which itself will connect to you over IPv6.

Using this method I was able to run a webserver, and had a friend in U.S. download from me at ~90Mbps (My Jio Speed is 100Mbps). This was probably helped by routing over Cloudflares network.

One caveat is - you cannot run services like FTP, SSH etc over Cloudflare, only web servers (on port 80 and 443 only, too). But for hosting Plex or something it works great.

Have fun!
 
Messages
40
Location
Ahmedabad
ISP
Reliance Jio150Mbps
I remember you mentioning that you got ipv6 to work on port 80. Is that correct?
Yes, it does work on port 80 and even 82 but not on any other port.
My setup:
my server(RPi4 4gb)--(ethernet)-->jio's ont.
I have checked using a port checker if my ports are open and the result is expected.
My ip- 2405:201:2002:8826:dea6:32ff:fe58:6c70
You can see if the ports for this ip is open on this site:ipv6 port checker
 
Messages
67
Location
Mumbai
ISP
Jiofibre
is your RPI currently powered on? and getting the same Ipv6 address as I just checked and unable to connect to it.
Port scan to the above IPv6 shows as filtered on all ports.

1. Can you check this on your RPI , by opening the browser on it and going to Test your IPv6.
2. What web service are you listening on the RPI ?
 
Messages
40
Location
Ahmedabad
ISP
Reliance Jio150Mbps
1. Can you check this on your RPI , by opening the browser on it and going to Test your IPv6.
jJ3fCIW.png

2. What web service are you listening on the RPI ?
My Minecraft server(only 5 people)- 25565 (port/tcp)
Jellyfin-8096 (port/tcp)
Open media vault-82 (port/tcp)
Nextcloud-8080 (port/tcp)
Nginx Proxy Manager-81,443,80 (port/tcp)
 
Messages
67
Location
Mumbai
ISP
Jiofibre
I checked your IPv6
1. Iam able to browse on port 82 - Webpage of openmediavault
2. Port scan shows the jellyfish port as being closed i.e port 8096
3.Following ports shows as open - ssh port 22, 139,445
4. 80 , 443, 8080, 8096 shows as closed

To check I installed JellyFish default port 8096
1. http://[2405:201:7:c002:6591:deb3:7be8:ea8e]:8096/
2. I find it works from out side just fine, you can check the same
3. We need to now check from your windows PC or on the RPI if you can internally telnet to port 8096, 8080 and also browse internally - Does it work fine on the Ipv6 addrees either directly on the RPI or from another device internally?
 
Messages
67
Location
Mumbai
ISP
Jiofibre
Yes from Mumbai. I get around 60 ms if I go via airtel. Which ISP are you using?
just fyi its hosted on a macmini , in case that makes a slight difference in response time’s
 
Messages
40
Location
Ahmedabad
ISP
Reliance Jio150Mbps
To check I installed JellyFish default port 8096
1. http://[2405:201:7:c002:6591:deb3:7be8:ea8e]:8096/
2. I find it works from out side just fine, you can check the same
3. We need to now check from your windows PC or on the RPI if you can internally telnet to port 8096, 8080 and also browse internally - Does it work fine on the Ipv6 addrees either directly on the RPI or from another device internally?
Yep, I can browse jellyfin internally using ipv4 not ipv6 and I can access your jellyfin server.
Note that my jellyfin is on docker
 
Messages
67
Location
Mumbai
ISP
Jiofibre
1.You need to get it working internally first using ipv6
2. Your issue therefore has nothing to do with connecting from outside.
3. You should mention everything that is being used in your setup.
4. Docker is a container and running in isolation. You need to enable the ipv6 Dameon in docker.
Has this been enabled? .
5. First check internally using ipv6 , if it works then only can it work from outside.