FTTH VOIP SIP Softphone configuration with ONT/ONU. (Now works on some more apps)

After hours of fiddling with my ONU and SIP apps, here is a guide on how to get it working.

First login to the ONU/ONT and change these things

voice1.jpg
Change VOICE to VOICE_INTERNET.

voice2.jpg
Add a Static Route to the SIP Server. You can add the IP directly like I did in my previous post. But that way you will have to add the return route too which is not there in my previous post. In my case, the return route is 10.x.x.x which is the same with my SIP server so I have to add only one route entry and be done.

voice3.jpg
If SIP is disabled, enable it and disable it again. This is necessary because SIP ALG functionality is broken. If it worked the way it was supposed to we could have easily setup softphones on our devices.

voice4.jpg
This is your VOIP config page. You wil find your SIP Server IP here. The proxy part isn't really necessary.

Also, you can disable IGMP on Voice. It's unnecessary.

voice5.jpg
Make sure NAT is enabled. Port Binding isn't necessary as we will be doing the setup on PC for now directly via ONT/ONU without any external router.

Hop to PC

Install YATE or MicroSIP and configure them with your SIP details. These are the two I have used that support NAT.

This goes without saying but just putting it out there. Allow the apps Windows Firewall prompt to connect to public network (or any other firewall you are using).

Configuration Screenshots

voice1.JPG
This is for MicroSIP. Click on the top right corner button -> Add Account. Don't forget to tick Allow IP Rewrite.

voice2.JPG
Another one for MicroSIP. Click on the top right corner button -> Settings. RTP ports range doesn't have to be that wide as I have in the Screenshot. 4000-4001 or 4010 is fine.

voice3.JPG
This is for YATE. Go to Settings -> Accounts -> Click on New

voice4.JPG
Resource Monitor showing MicroSIP info when it's idle not dialing any number.

voice5.JPG
Resource Monitor showing MicroSIP info when I dialed a number. See the change under Network Activity. Now there is another IP which will receive voice and reply which I will receive on my static VOIP IP which NAT will take care of and send to my local IP.

Link to previous failed attempt.

New changes that will let VOIP work on some more apps and platforms.

Tick "Turn off LAN DHCP" on Voice Internet configuration and Enable SIP ALG. Didn't think disabling DHCP makes SIP ALG function properly. Really hard to know which option does what without a proper manual.

Also, those who have DHCP instead of Static in Voice Internet configuration, everything else is same.
 
Last edited:
Messages
11
Location
Sitapur
ISP
BSNL
Hi, I have done everything correct (i think), but there is a issue it only works and comes online when I check the port binding to the SSID, and when I do that the internet stops working on that secific SSID.
to work around that have now created a new SSID i.e. SSID 2 in WAN 3 and the app now comes online and I am able to receive and make calls but now I am only able to access internet on SSID 1 & 5 in WAN 1.
But if I uncheck all the SSID's then the app doesnt want to get registered

Screenshot of settings

Is there any work around this?

I am using Huawei EG8145v5
 
Messages
501
Location
India
ISP
Airtel | Jio | V! | BSNL
@sulhjafri

Configuration for VOIP/SIP calls( using Zoiper/GS Wave) on Huawei ONT and TP Link Router. | BSNL Bharat Fiber Broadband

Using Huawei ONT as router also won’t work. They have weird port closing rules set up in the router software if port binding isn’t enabled. It essentially closes SIP ports on unbound LAN ports including WLAN SSIDs. So use the ONT modem in bridge mode with another customisable router, if you want to use sofphone clients.

Or easy, and imo, the best solution is to get a cordless phone. It saves your phones battery.
 
Last edited:
Messages
11
Location
Sitapur
ISP
BSNL
@pillaicha

Thanks for the help, I do have a cordless phone connected to the loop as well.
I was just not sure why I could not get both internet and sip to work at the same time.
Now I know why.
 
Last edited: