dataone-Intex LAN card+linux

  • Thread starter tux21
  • Start date
  • Replies: Replies 32
  • Views: Views 17,195
T

tux21

Newbie
Messages
27
Location
NA
Hi ,I recently purchased an intex rtl8139d lan card.Beaware that this card is not a genuine Realteck card and so will not workwith KERNEL 2.6. Driver provided might compile with 2.4.The chipset it uses is called sc92031 manufactured by Silan Microelectronics , China.the windows driver it provides is written to fool the user to show REALTEK8139D on the system menu.If anyone has this working on kernel 2.6 plz let me know.the label on the IC read rtc8139 not rtl8139 (rs.250/-)
 
P

Positron

Regular
Messages
111
Location
NA
I got Intex LAN card for 180 bucks about 8 months ago and Micr0nsoft XP detects it as RTL8139 which is pretty fine. It also gets automatically detected by SuSE 10.0(dont know whats the kernel version) B)
 
T

tux21

Newbie
Messages
27
Location
NA
positron type uname -r command in the bash shell of linux and please tell what the output is .
 
T

tux21

Newbie
Messages
27
Location
NA
Oh !So it worked for 2.6 kernel for u.well i purchased it on 4th feb '06.probably now what they use is incompatible with kernel 2.6.x ?If anyone has recently prchased and used it with kernel 2.6 please post me the drivers.
 
P

power

supersupersuper...
Messages
1,343
Location
NA
ISP
TATA+Sify
you dont need to compile kernel again with the driver provided with it . All intex lancards work well with 2.4x and 2.6x kernel . I had 2 different intex lancards and almost all linux distros i tried took it properly by themselves . Most of them used rtl8139 driver
 


T

tux21

Newbie
Messages
27
Location
NA
But my card somehow doesn't work.I repeat that it is new and thats why.the people at intex sevice centre told me abt this problem.I don't think i missed any steps in loading modules fealnx ,8139too , infact all the modules forlan cards in kernel 2.6.12 working with FEDORA CORE 1.The lspci output shows device ID 1904:2031 FOR UNKNOWN ETHERNET CONTROLLER.please help !
 
P

power

supersupersuper...
Messages
1,343
Location
NA
ISP
TATA+Sify
Well then have u tried ndiswrapper ?
 
T

tux21

Newbie
Messages
27
Location
NA
My lspci output is 01:01.0 Ethernet controller: Unknown device 1904:2031 (rev 01)The reason why 2031 appears not 8139 is because my lan card chipset is sc92031.If anyone has this output plz enter this thread.
 
T

tux21

Newbie
Messages
27
Location
NA
I have mailed Silan microelectronics to provide the driver for kernel 2.6 .If anyone could compile sc92031.c in 2.6 kernel, help me out.
 
T

tux21

Newbie
Messages
27
Location
NA
the information for silan sc92031 ic is attached in the following text file i painstakingly compiled from net
 
P

power

supersupersuper...
Messages
1,343
Location
NA
ISP
TATA+Sify
NdisWrapper

Some vendors do not release specifications of the hardware or provide a linux driver for their wireless network cards. This project implements Windows kernel API and NDIS (Network Driver Interface Specification) API within Linux kernel. A Windows driver for wireless network card is then linked to this implementation so that the driver runs natively, as though it is in Windows, without binary emulation.[/b]

http://ndiswrapper.sourceforge.net/

Try installing this once . If you just want to check if it works then dlaod latest knoppix it has ndiswrapper in it by default and see if it works in knoppix then it should work on ur installed distro tooo . You need the lancard driver for windows though
 
P

power

supersupersuper...
Messages
1,343
Location
NA
ISP
TATA+Sify
ooh btw dont get confused by wireless written up it should work for ethernet's toooo
 
T

tux21

Newbie
Messages
27
Location
NA
i have installed it ,loaded modules ndiswrapper and also installed winxp driver .Here is output for ndiswrapper -l[[email protected] root]# ndiswrapper -lperl: warning: Setting locale failed.perl: warning: Please check that your locale settings: LANGUAGE = (unset), LC_ALL = (unset), LANG = "en_US.UTF-8" are supported and installed on your system.perl: warning: Falling back to the standard locale ("C").Installed drivers:netslnt driver installedBut it doesn't show device present ???