Configuration BSNL FTTH VOIP GJ region. (MicroSIP, Zoiper5, Default Android Dialer, Zoiper Android)

Hello All,

I wanted to share with you the basic BSNL FTTH VOIP configuration for Gujarat region.
I have a Fiber Basic Plan for testing purpose on which I have somehow managed to get VOIP working decently.

Below is what I did (summarized) - ONT - Syrotech (WIFI Model with 2GB LANS + 1 POTS).
*** For Gujarat region
*** You must have a proper working VOIP Profile set in your ONT, i.e., your ONT should show your VOIP number as Registered.

1. Change VOICE Profile in Network to VOICE_INTERNET. Check Turn of LAN DHCP. Bind to any one LAN PORT.
2. 802.1p - NULL.
3. IP Protocol - IP4 Only.
4. DHCP Mode.
5. VLAN - For 299 series 1849.
6. Enable NAT.
7. Request DNS - Enabled.
8. Add Static Route to ONT Destination - 10.0.0.0 Subnet - 255.0.0.0 Gateway - YOUR VOIP Gateway(10.x.x.x) Metric - 0 Interface - VOICE_INTERNET.
9. Enable UPNP for VOICE_INTERNET.
10. Change NAT to 1.
11. Disable SIP in ALG Configuration. (Enable if disabled then disable again, i don't know why this works).
12. Insert LAN Cable in the Port selected in point 1 and connect other end to WAN of any old Wireless / Wired Router.
13. Open Router admin page and set its WAN to Static IP and enter one of the ONT LAN IP (eg. 192.168.1.10, if your ONT is at 192.168.1.1).
14. Enter WAN DNS manually Primary - 172.30.249.33 and Secondary - 172.30.249.11.
15. Set the Router LAN IP to anything other than 192.168.1.x subnet (eg. set it to 192.168.0.1).
16. Enable DHCP in router and change DNS as above in point 5.
17. Save router settings and reboot.
18. Ping your default VOIP gateway(10.x.x.x) from a PC connected to the router network (eg. 192.168.0.2). If ping okay then continue else you messed up something, try again from the beginning.
--MicroSIP specific--
19. Download MicroSIP or Zoiper5 on Windows PC (MicroSIP is available for Linux too)
20. Open MicroSIP - Create new account. Username, Login, Display name is your phone number (eg. +91 + std code without leading zero + your number).
21. Password is ftth@last 4 digits of your number.
22. SIP Server/Proxy/Domain is gj.ftth.ims.bsnl.in (your circle might have utstarcom core instead of Huawei, if so, use gj.ftth.utims.bsnl.in).
23. Select Transport UDP.
24. Click Save. If all goes well you'll be registered and see green icon on MicroSIP. It may take many tries (5 to 10 minutes before being successful).
--Zoiper5 specific--
25. Open Zoiper5 free edition.
26. Login - is your phone number (eg. +91 + std code without leading zero + your number).
26. Password is ftth@last 4 digits of your number.
27. SIP Server - gj.ftth.ims.bsnl.in (your circle might have utstarcom core instead of huawei, if so, use gj.ftth.utims.bsnl.in).
28. Tick authentication and outbound proxy.
29. Outbound proxy - gj.ftth.ims.bsnl.in (your circle might have utstarcom core instead of huawei, if so, use gj.ftth.utims.bsnl.in).
30. Leave authentication username id empty.
31. Zoiper will show which protocol it found and add the account and make it active.
--Default Android Dialer--
32. Go to call settings - calling accounts - add SIP account.
33. SIP Server - gj.ftth.ims.bsnl.in (your circle might have utstarcom core instead of huawei, if so, use gj.ftth.utims.bsnl.in).
34.Username - is your phone number (eg. +91 + std code without leading zero + your number).
35. Password is ftth@last 4 digits of your number.
34. Advanced SIP settings - outbound proxy same as SIP Server.
35. SIP Server Port - 5060.
36. Protocol - UDP (TCP connects but I didn't get any sound).
37. Keep Alive - Automatic.
38. Save account. It will display something like checking status and then 10 - 15 seconds later it will be registered.
--Zoiper Android--
39. Refer to Zoiper5 settings as they are same on android too.

I am willing to help at my spare / free time only, through email only no remote configuration.

Hope that you get your VOIP going as well.
Best regards.
Nikki
 
Messages
11
Location
NA
👏appreciate your effort for putting in summarized way from sloj thread.

Regular BSNL old telephone working fine.

had done everything from point 1 to 12 and microsip specific steps.
microsip displays "Bad gateway".

ping from diagnosis tab from ONT is without loss from SIP gateway as well as voice ip(SIP)
ping from desktop to SIP gateway is OK but ping to SIP IP 100% loss.

gs wave app displays fail to register.

Under VOIP tried both SIP and IMS option as well as change in VOIP advance configuration INBAND,SIP ,still no difference.

are you know SIP IP address of western region instead of domain name gj.ftth.ims.bsnl.in and outbound proxy ip ?
 
Last edited:
Messages
11
Location
NA
@tirth

Bsnl phone is working fine but whenever i got call it display NO CLI .
Do you know solution?

dont know how to upload images so here all in text format.

Device info

Hardware Version V3.7L
SoftWare Version 3.0.01-210617

NetWork Info

1_INTERNET_R_VID_xxx​
xxx​
PPPoE​
Enable​
up​
59.x.x.x​
255.255.255.255​
2_VOICE_INTERNET_R_VID_1849​
1849​
IPoE​
Enable​
up​
10.146.xxx.xxx​
255.255.254.0​


1_INTERNET_R_VID_xxx​
117.x.x.x​
218.248.114.65​
218.248.114.1​
2_VOICE_INTERNET_R_VID_1849​
10.146.xxy.z​
172.30.249.33​
172.30.249.11​


VOIP Information
Service State Registered
Phone Number +91xxxxxxxxx

WAN configuration
2_voice_internet_r_vid_1849
Differences :
802p--- > 7
MTU ---> 1500

NAT Configuration --- > NAT1

Route -- Statix Route

Enable​
10.0.0.0​
255.0.0.0​
10.146.xxy.z​
1​
nas0_0​


VOIP Configuration
Differences
Server Type ---- > SOFT SWITCH SIP / IMS SIP
SIP Register address ----> gj.ftth.ims.bsnl.in

Ping Diagnose

PING Test

Dest IP Address:10.146.xxy.z
WAN Interface:2_voice_internet_r_vid_1849

Ping 10.146.xxy.z
64 bytes from 10.146.xxy.z: seq=0 ttl=64 time=10.000 ms
64 bytes from 10.146.xxy.z: seq=1 ttl=64 time=0.000 ms

--- 10.146.xxy.z ping statistics ---
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max = 0.000/2.500/10.000 ms


Dest IP Address:10.146.xxx.xxx
WAN Interface:2_voice_internet_r_vid_1849

Ping 10.146.xxy.z
64 bytes from 10.146.xxx.xxx: seq=0 ttl=64 time=10.000 ms
64 bytes from 10.146.xxx.xxx: seq=1 ttl=64 time=0.000 ms

--- 10.146.xxx.x ping statistics ---
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max = 0.000/2.500/10.000 ms

sometime got this error
Destination or WAN interface is wrong!


CMD ping

C:\Windows\System32>ping 10.146.xxy.z

Pinging 10.146.xxy.z with 32 bytes of data:
Reply from 10.146.xxy.z: bytes=32 time=3ms TTL=63
Reply from 10.146.xxy.z: bytes=32 time=5ms TTL=63
Reply from 10.146.xxy.z: bytes=32 time=3ms TTL=63
Reply from 10.146.xxy.z: bytes=32 time=3ms TTL=63

Ping statistics for 10.146.xxy.z:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 3ms, Maximum = 5ms, Average = 3ms

C:\Windows\System32>ping 10.146.xxx.xxx

Pinging 10.146.xxx.xxx with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 10.146.xxx.xxx:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
 
Last edited:
Messages
4
Location
Himalayas
ISP
BSNL FTTH
Hello all,
Sorry couldn't check the replies sooner.

@tirth i think you have solved your problems, good for you.

As for @WATER_the_life do not ping the SIP IP Address that you get assigned it will never work. If SIP gateway ping is all okay then try to ping the SIP server gj.ftth.ims.bsnl.in (for me it is - 10.191.181.49 - this is the main registrar server) for incoming call audio the servers vary from .50 to .56

If your pc is having problems to ping SIP server then close and exit MicroSIP completely. open and edit your hosts (system32/drivers/etc) and add the following
#ip address hostname
10.x.x.x gj.ftth.ims.bsnl.in
#your SIP server IP (from resmon) or try 10.191.181.49 gj.ftth.ims.bsnl.in
save and exit editor and try to ping SIP server by hostname not IP, if all well then ping will be good else something else is amiss.

how to find SIP IP address might work for everyone as it is completely generic solution.
Start Resource Monitor (Win + R + resmon) - go to networking tab - start microsip - select (check mark it) microsip in resmon - see network traffic and ports being used, if ports are closed open them from your firewall then make microsip active - check resmon for IP where MicroSIP tries to make connection to that IP will most likely be the registrar server so note it down. Keep in mind for this to work you should use your VOIP wifi or wired network which only has VOIP_INTERNET WAN access and not INTERNET. Also just to be safe enter dns manually in your windows settings (networking - adapter).

----My observations using softphones----
It is quite a task but the end result isn't that satisfactory to be honest, SIP Softphones on my mobiles (OnePlus 6, Sony Xperia Z5, Apple iPhone 8 Plus, Micromax Canvas Knight A350, Asus Zenphone Max Pro M1, Samsung Galaxy S20) do work but after a while when the phone goes in deep sleep / suspend mode then there is no incoming call notification till you disconnect and re-register you softphone (applies for android os only, iOS doesn't seem to have this issue), i don't know about others. Also different SIP clients have different codecs which is quite a different mess altogether. Only use PCMU and PCMA (ulaw and alaw) for audio compatibility issues at-least that is what worked for me. MicroSIP works just great on PC no issues at all crisp clear calls. I got best results with PortSIP UC on android devices but that application does not run in background even if it says that it does it plain exits when in background. The second best for android is Grandstream Wave Lite but it too doesn't work after deep sleep. For iOS i used Zoiper, Acrobit and Groundwire all work and there isn't the android problem of not ringing when in deep sleep / suspend. For Linux I used MicroSIP (you need Wine to run windows app in linux) else Zoiper works just fine.
If you have a cordless phone use it and relax. :)
 
Last edited:
Messages
4
Location
Himalayas
ISP
BSNL FTTH
👏appreciate your effort for putting in summarized way from sloj thread.

Regular BSNL old telephone working fine.

had done everything from point 1 to 12 and microsip specific steps.
microsip displays "Bad gateway".

see my reply to find SIP Server IP.
I have no idea what that NO CLI is, but likely it is Caller Line Identification so it tells you who is calling as far as I have tested, you can set your own name as CLI for SIP calls. Just change display name to whatever you want the CLI system to display, i maybe wrong but since you are receiving most likely that remote host has misconfiguration (your host / core may also be misconfigured).
Also you can't ping VOIP IP assigned to you. MicroSIP bad gateway means that it isn't able to find DNS route for gj.ftth.ims.bsnl.in.
Since you are able to ping gateway edit hosts files and you are good to go.

Hope your queries are solved.
 
Last edited: