Certain apps (Twitter, amazon prime, netflix not working over wifi(MTNL FTTH) but work over mobile internet)

spaceboy13

I got banned!
Messages
38
Location
NA
ISP
MTNL FTTH
I have 500 mbps fiber setup at home installed by MTNL a week ago. I have found that on my android note 9 certain apps like netflix, twitter, prime video, Amazon shopping (But Youtube works) dont work. They are also not accessible on mobile using a web browser.

But they work fine on mobile internet. Running these websites on my laptop they work fine over wifi. I also found that my Sony android smart tv is facing the same problem with the same apps not working.

I tested these apps on an iPhone-they worked fine. They also worked fine on oneplus7 (Running Android 10)

I have rummaged forums and platforms trying to solve this problem but no help so far. My wifi setup is as follows:

GPON Router(Alphion 1601)----TP-Link Router AC1900(Setup as an accesspoint)--- My android device

Also on my phone by using a VPN I gain access to these apps.

I have tried directly connecting to Wifi of the Alphion 1601 router given by MTNL. The apps dont work on it which means that TP Link router is not a problem.

I attempted bridging on Alphion thinking that it might solve the problem but could not do it since I dont know VLAN ID.

I have done the conventional steps of clearing cache on mobile, software update check, restarting and uplugging the router.

Pl I need your help since the ftth connection will be a waste if apps like netflix, prime video dont work especially on the sony bravia android tv
 

Kick933

Still Learning
Messages
483
Location
Haryana
ISP
BSNL FTTH
Please check if you have IPV4 and IPV6 bother enabled on alpphion ONT.
Also,DHCP for both should be activated for minimal disruption due to any conflicts...
 

sanke3

I got banned!
Messages
312
Location
NA
ISP
MTNL FTTH
Make sure you have correct MTU. It’s either 1480 or 1492. Also make sure that you are using Google DNS 8.8.8.8 and 8.8.4.4 in your ONU or router whichever is dialing PPPOe connection.

For Alphion ONUs the default login is admin and password is system
You can get your VLAN ID from Alphion ONU’s interface.
 

spaceboy13

I got banned!
Messages
38
Location
NA
ISP
MTNL FTTH
Please check if you have IPV4 and IPV6 bother enabled on alpphion ONT.
Also,DHCP for both should be activated for minimal disruption due to any conflicts...
Thanks so much for replying. IPV6 isn't configured in my router. Can you tell me the steps for Alphion. I am able to login to the router w/ o any issues.
 

spaceboy13

I got banned!
Messages
38
Location
NA
ISP
MTNL FTTH
Make sure you have correct MTU. It’s either 1480 or 1492. Also make sure that you are using Google DNS 8.8.8.8 and 8.8.4.4 in your ONU or router whichever is dialing PPPOe connection.

For Alphion ONUs the default login is admin and password is system
You can get your VLAN ID from Alphion ONU’s interface.
Thanks sanke3 for replying. I also did this research regarding MTU issue. But on ONT router there is no option to change the MTU. I checked specs on Alphion website, I think it is 2000 by default.

Have tried making Dns static and putting Google DNs in it but did not make any difference. Also VLAN ID by default is -1 and disabled which means it is untagged.
 

spaceboy13

I got banned!
Messages
38
Location
NA
ISP
MTNL FTTH
Please check if you have IPV4 and IPV6 bother enabled on alpphion ONT.
Also,DHCP for both should be activated for minimal disruption due to any conflicts...
I managed to setup IPv6 on the Alphion ONT. This is what I did...

1. Create New WAN profile and selected dual stack IPV6.
2. Then enabled Lan IPV6 autoconfig

Now it shows IPV6 enabled..but still no access to apps like Netflix, Amazon on Note9/ Smart TV
 


a.c

Messages
651
Location
Delhi
ISP
Excitel
I was facing the same issue in my case it was a MTU mismatch problem. I have multiple routers and access points. You have to make sure that all of them have to same MTU as 1492 (or whatever it is for you). After I fixed the MTU all websites started working on all devices.
 

Kick933

Still Learning
Messages
483
Location
Haryana
ISP
BSNL FTTH
@achaudhary997 @spaceboy13
Yes,this may be an issue as older models did not auto-negotiate for MTU size.
And considering that you have Alphion ONT,we can conclude that OLT is also Alphion branded.So,We can also put finger on the point that the OLT may be very old and need specified MTU match instead of automatic negotiation.
So,try the most common values including 1492 and 1480.
You can find it in the admin page on your ONT.Please search for it.
 

spaceboy13

I got banned!
Messages
38
Location
NA
ISP
MTNL FTTH
Please check if you have IPV4 and IPV6 bother enabled on alpphion ONT.
Also,DHCP for both should be activated for minimal disruption due to any conflicts...
I managed to setup IPv6 on the Alphion ONT. This is what I did...

1. Create New WAN profile and selected dual stack IPV6.
2. Then enabled Lan IPV6 autoconfig

Now it shows IPV6 enabled..but still no access to apps like Netflix, Amazon on Note9/ Smart TV
 

spaceboy13

I got banned!
Messages
38
Location
NA
ISP
MTNL FTTH
I was facing the same issue in my case it was a MTU mismatch problem. I have multiple routers and access points. You have to make sure that all of them have to same MTU as 1492 (or whatever it is for you). After I fixed the MTU all websites started working on all devices.
Thanx @achaudhary997 for helping out. Problem is I cant find the MTU setting option in the Alphion ONT. That's why I was trying to bridge it so that I could use my TP-Link router for settings where I could MTU value. But bridging did not work sadly.
 

spaceboy13

I got banned!
Messages
38
Location
NA
ISP
MTNL FTTH
@achaudhary997 @spaceboy13
Yes,this may be an issue as older models did not auto-negotiate for MTU size.
And considering that you have Alphion ONT,we can conclude that OLT is also Alphion branded.So,We can also put finger on the point that the OLT may be very old and need specified MTU match instead of automatic negotiation.
So,try the most common values including 1492 and 1480.
You can find it in the admin page on your ONT.Please search for it.
Went through manually each setting in the router page. Cant find option to set MTU value in Alphion 1601. Would be glad if someone could help
 

sanke3

I got banned!
Messages
312
Location
NA
ISP
MTNL FTTH
my Alphion ONU has the MTU option. It's on the same page where you edit PPPOe settings like your username and password. You can call up MTNL customer care and ask them to put your ONU into Bridge mode via TR-069 remote management. That's how they put my ONU in bridge mode. Now it doesn't allow me to even reset it. Alphion ONUs are all generally defective and do not respond to setting changes after few months. Same has happened to 2 of my earlier Alphion ONUs.
 

spaceboy13

I got banned!
Messages
38
Location
NA
ISP
MTNL FTTH
my Alphion ONU has the MTU option. It's on the same page where you edit PPPOe settings like your username and password. You can call up MTNL customer care and ask them to put your ONU into Bridge mode via TR-069 remote management. That's how they put my ONU in bridge mode. Now it doesn't allow me to even reset it. Alphion ONUs are all generally defective and do not respond to setting changes after few months. Same has happened to 2 of my earlier Alphion ONUs.
What is your Alphion ont version. Mine is Alphion 1601. I went into the Wan service where PPPOE mode is selected and user details are mentioned but the MTU setting is not showing. Can you share a screenshot of the mtu setting if possible. Are all your websites/ apps opening in bridge mode.

Also Can I set bridged mode on my own since Customer care is tough to reach( always busy). I tried doing bridge mode but I think Vlan ID was incorrect and it didn't work. With Bridge mode I can use my TP-Link for the mtu setting probably.