Broadband not working despite all lights active

#1
Hi,
My router is D-link dsl-2750u.
Broadband is not working from today morning, despite all modem lights active, I don't know if pays are due, I tried to load freetrialbsnl it won't load neither. Windows troubleshooter says DNS not responding,windows can't communicate with the device or resource. WAN IP, gateway is 10.0.0.1, 10.0.x.x instead of BSNL. In router stats I see BSNL DNS Server. If I try to ping DNS from Cmd I get request timed out. In diagnostic test, for everything in ADSL & Internet connect, failed. I tried setting windows, Router DNS to automatic, resetting router, still same.
What could be cause?
 
Last edited:

varkey

Newbie
Regulars
#2
What does the ADSL stats of the modem show? Is the PPP connection active?

Also are you able to ping an IP address? Say 8.8.8.8?
 

varkey

Newbie
Regulars
#4
^ That PPPoE config doesn't look right, especially the IP address etc. Are you sure its configured properly? It *appears* as though you have a static IP defined, cause AFAIK BSNL doesn't issue IP addresses in that series.
 
#5
I haven't touched any setting, I just factory reset router, reconfigured basic settings
Source

This time my wan ip shifted to 10.0.2.97
also this is not first time this kind of thing is happened, when bill is due, cut, few times, IP address range'd change from common one when net is working to different range, then automatically shift after activated.