Billing

hitman

Regulars
[OP]
May 10, 2005
2,678
71
New Delhi
Any idea when will i get my first bill ? I got connection on 30th july. As far as i know they do billing from 15th of every month. but i haven't got any bill as yet....
 

Vince

Regular
Regulars
May 23, 2005
317
0
Look out for that first bill hitman!i got my connection on the 29th of June..I got billed Rs.1800!! Even though i'm on a Rs.800 unlimited plan...I was charged 800 bucks under some prorata monthly thingy???I called customer care, but they repeat the same thing from the website....i Still dont understand... but the second bill better be rs.800, or i'll kill them...
 

Vince

Regular
Regulars
May 23, 2005
317
0
Oh and another thing that happened to me is that my bill a bit late too!!So keep your cash ready....it came exactly the day i was to leave on a tour to Kerala for a week, so i had to pay the bill as soon as i returned home...
 


hitman

Regulars
[OP]
May 10, 2005
2,678
71
New Delhi
Ya got my bill amounting to Rs. 3586 on the website and which contain 1679.00 as pro rata charges. Let the bill come and i will then see how they charge tht amount.
 

hitman

Regulars
[OP]
May 10, 2005
2,678
71
New Delhi
Ok just called the cc and got this answer. I got my connection on 30th july. The POSTPAID plan is actually not postpaid it is same as prepaid. The pro rata bill of 1679 Rs I got was of 1 day of month of july + month of august and added to it was the monty charges of 1575 Rs for month of september . So now the next bill which i will get will be of Rs 1575. This explanation indeed is very strange as it defeats the purpose of calling the connection as postpaid or prepaid. Terrible abolutely terrible. Although i must say i didn't even have a min of downtime from tata for last one month but this billing funda just washed away their good service which so far they have provided.
 

Vince

Regular
Regulars
May 23, 2005
317
0
But you know why its even more infuriating?I had applied in the last week of May, and my connection should've been ready by the 2nd week of June.... But they messed up my application, so i had to apply again, by which time they gave the connection only on the 29th of June!So i have to pay extra....for THEIR fault!!!
 


Vince

Regular
Regulars
May 23, 2005
317
0
BTW, have you used the net telephony feature? i've used it a couple of times, its OK...
 

Similar threads