WPA2 PSK security enabled Wifi not connecting in Micromax Funbook Tablet PC

gijo

Newbie
[OP]
Aug 15, 2012
3
0
I have broadband wifi at home (NetGear N300 Wireless ADSL2 +Modem Router) which has WPA2 PSK security lock.When I tried to connect my new Micromax Funbook with Wifi, the wireless network is detected with WPA2 PSK security. On entering the password, immediately the "Connect" button link fades off and become inaccessible. For some other detected networks which are WEP security enabled, while typing password, it does not happen and I think I can connect if I knew their actual Password. The "connect" becomes inaccessible only for WPA2 and WPA security enabled Wifi.Friends, kindly help me to resolve this problem and get connected with Wifi.
 

sachinbr

Regular
Regulars
Apr 27, 2011
759
35
Kindly help me to resolve this...please...
This might be due to password length. So reduce ur password size n try
 


gijo

Newbie
[OP]
Aug 15, 2012
3
0
This might be due to password length. So reduce ur password size n try

Dear Sachinbr, Thanks for ur reply. Since even typing a single letter of password disabled the connect option, I realized that Funbook may not be accepting WPA2 security options. Hence I managed to change my router security from WPA2 to WEP. Then it accepted the new password generated by the system, which was long one (13 character) and wifi is working fine.
 

Similar threads