Screwed up routes in BSNL

elepton

Regular
[OP]
Regulars
Apr 11, 2007
162
5
So pings from Bangalore to Mumbai are going through the US. Wow.

Code:
$ date; traceroute ix-0-100.tcore1.MLV-Mumbai.as6453.net.Sat May 19 04:01:12 IST 2012traceroute to ix-0-100.tcore1.MLV-Mumbai.as6453.net. (180.87.38.5), 30 hops max, 60 byte packets 1  117.205.xxx.1 (117.205.xxx.1)  6.427 ms  8.074 ms  10.022 ms 2  218.248.175.246 (218.248.175.246)  15.949 ms  17.864 ms  20.293 ms 3  if-11-1-1.mcore3.LAA-LosAngeles.as6453.net (209.58.85.5)  268.408 ms  270.864 ms  272.818 ms 4  if-10-2-0-14.tcore2.LVW-LosAngeles.as6453.net (216.6.84.6)  313.430 ms  315.158 ms  316.782 ms 5  if-7-2.tcore2.SVW-Singapore.as6453.net (180.87.15.25)  318.833 ms  320.807 ms  316.103 ms 6  ix-0-100.tcore1.MLV-Mumbai.as6453.net (180.87.38.5)  318.950 ms  327.324 ms  335.153 ms$ ping ix-0-100.tcore1.MLV-Mumbai.as6453.net.PING ix-0-100.tcore1.MLV-Mumbai.as6453.net (180.87.38.5) 56(84) bytes of data.64 bytes from ix-0-100.tcore1.MLV-Mumbai.as6453.net (180.87.38.5): icmp_req=1 ttl=56 time=289 ms64 bytes from ix-0-100.tcore1.MLV-Mumbai.as6453.net (180.87.38.5): icmp_req=2 ttl=56 time=304 ms64 bytes from ix-0-100.tcore1.MLV-Mumbai.as6453.net (180.87.38.5): icmp_req=3 ttl=56 time=292 ms64 bytes from ix-0-100.tcore1.MLV-Mumbai.as6453.net (180.87.38.5): icmp_req=4 ttl=56 time=356 ms^C--- ix-0-100.tcore1.MLV-Mumbai.as6453.net ping statistics ---4 packets transmitted, 4 received, 0% packet loss, time 3003msrtt min/avg/max/mdev = 289.575/310.792/356.721/27.079 ms
 

protoyu

Newbie
Dec 26, 2011
13
0
Right now half of the internet wont open here. Any ideas?I tracert many of them and saw connections dont go out of NIB's routing circles...clearly something is broken in the route.Anybody else experiencing this?
 

elepton

Regular
[OP]
Regulars
Apr 11, 2007
162
5
Yes! A lot of site aren't opening for me either. I thought this was an isolated issue on my connection as much more sites are opening in another node in my city which is also on NIB-II.

Example (on my connection):
Code:
$ date; traceroute a.gtld-servers.netSat May 19 06:17:12 IST 2012traceroute to a.gtld-servers.net (192.5.6.30), 30 hops max, 60 byte packets 1  117.205.xxx.1 (117.205.xxx.1)  6.932 ms  8.786 ms  10.761 ms 2  218.248.175.246 (218.248.175.246)  18.351 ms  19.059 ms  20.797 ms 3  * * * 4  * * * 5  * * * 6  * * * 7  * * * 8  * * * 9  * * *10  * * *11  * * *12  * * *13  * * *14  * * *15  * * *16  * * *17  * * *18  * * *19  * * *20  * * *21  * * *22  * * *23  * * *24  * * *25  * * *26  * * *27  * * *28  * * *29  * * *30  * * *$ date; traceroute microsoft.comSat May 19 06:17:49 IST 2012traceroute to microsoft.com (64.4.11.37), 30 hops max, 60 byte packets 1  117.205.xxx.1 (117.205.xxx.1)  6.291 ms  7.926 ms  9.882 ms 2  218.248.175.246 (218.248.175.246)  16.276 ms  17.727 ms  19.642 ms 3  * * * 4  * * * 5  * * * 6  * * * 7  * * * 8  * * * 9  * * *10  * * *11  * * *12  * * *13  * * *14  * * *15  * * *16  * * *17  * * *18  * * *19  * * *20  * * *21  * * *22  * * *23  * * *24  * * *25  * * *26  * * *27  * * *28  * * *29  * * *30  * * *
On a different connection which is also on NIB-II in my city:
Code:
$ date; traceroute a.gtld-servers.netSat May 19 06:18:48 IST 2012traceroute to a.gtld-servers.net (192.5.6.30), 30 hops max, 60 byte packets 1  192.168.0.98 (192.168.0.98)  0.301 ms  0.424 ms  0.801 ms 2  192.168.1.1 (192.168.1.1)  4.199 ms  4.268 ms  4.332 ms 3  117.205.xxx.1 (117.205.xxx.1)  20.560 ms  22.072 ms  24.816 ms 4  218.248.175.246 (218.248.175.246)  28.431 ms  31.146 ms  31.345 ms 5  59.163.201.149.static.chennai.vsnl.net.in (59.163.201.149)  79.657 ms  80.355 ms  82.531 ms 6  172.31.19.149 (172.31.19.149)  109.581 ms  105.641 ms  111.639 ms 7  ix-0-100.tcore1.MLV-Mumbai.as6453.net (180.87.38.5)  112.495 ms  115.391 ms 172.29.250.33 (172.29.250.33)  117.119 ms 8  if-2-2.tcore2.MLV-Mumbai.as6453.net (180.87.38.2)  246.677 ms  234.272 ms  235.566 ms 9  if-6-2.tcore1.L78-London.as6453.net (80.231.130.5)  224.412 ms  206.102 ms if-2-2.tcore2.MLV-Mumbai.as6453.net (180.87.38.2)  229.303 ms10  if-6-2.tcore1.L78-London.as6453.net (80.231.130.5)  221.363 ms  230.764 ms Vlan704.icore1.LDN-London.as6453.net (80.231.130.10)  240.801 ms11  xe-1-1-0.r2.bb-fo.lon3.vrsn.net (195.66.225.46)  236.781 ms  240.295 ms  229.442 ms12  199.16.94.153 (199.16.94.153)  236.158 ms  235.884 ms  236.736 ms13  199.16.94.153 (199.16.94.153)  245.117 ms 199.16.94.13 (199.16.94.13)  312.622 ms  348.307 ms14  199.16.94.13 (199.16.94.13)  312.799 ms 199.16.94.6 (199.16.94.6)  348.493 ms  308.348 ms15  199.16.94.90 (199.16.94.90)  334.631 ms  339.221 ms  339.787 ms16  199.16.95.42 (199.16.95.42)  331.682 ms 199.16.94.98 (199.16.94.98)  353.081 ms 199.16.95.42 (199.16.95.42)  331.665 ms17  199.16.95.42 (199.16.95.42)  331.780 ms 199.7.51.158 (199.7.51.158)  359.605 ms 199.16.95.90 (199.16.95.90)  338.570 ms18  199.7.51.162 (199.7.51.162)  353.083 ms  362.484 ms  364.876 ms19  * * *20  * * *21  * * *22  * * *23  * * *24  * * *25  * * *26  * * *27  * * *28  * * *29  * * *30  * * *$ date; traceroute microsoft.comSat May 19 06:21:22 IST 2012traceroute to microsoft.com (64.4.11.37), 30 hops max, 60 byte packets 1  192.168.0.98 (192.168.0.98)  0.363 ms  0.748 ms  0.880 ms 2  192.168.1.1 (192.168.1.1)  4.303 ms  4.348 ms  4.414 ms 3  117.205.xxx.1 (117.205.xxx.1)  18.792 ms  20.273 ms  23.051 ms 4  218.248.175.246 (218.248.175.246)  25.783 ms  27.301 ms  28.565 ms 5  * * * 6  * * * 7  * * * 8  * * * 9  * * *10  * * *11  * * *12  * * *13  * * *14  * * *15  * * *16  * * *17  * * *18  * * *19  * * *20  * * *21  * * *22  * * *23  * * *24  * * *25  * * *26  * * *27  * * *28  * * *29  * * *30  * * *
This is very weird as the same router is routing connections to a.gtld-servers.net (one of the .com and .net DNS servers) for one customer but not for the other customer.

microsoft.com is not working on both connections.

hidemyass.com is working fine so until this is fixed, that is an easy way to browse the sites that are not opening.

From my further investigations, routes to Singapore, Japan are working; some routes to US are working but some are not; routes to Europe are not at all working.
 


elepton

Regular
[OP]
Regulars
Apr 11, 2007
162
5
More likely routes in the BSNL routers got bad or maybe it's a hardware failure somewhere.Could you confirm that the first IP address in your traceroute is 117.205.160.1? :p
 

protoyu

Newbie
Dec 26, 2011
13
0
Nope Lol its not...Let the geniuses at BSNL wake up and fix this else this is worse than anything. even imgur wont open.
 


protoyu

Newbie
Dec 26, 2011
13
0
ya Im in Kolkata all right...The first ip that comes is my home ip.edit : seems solved for now.
 

elepton

Regular
[OP]
Regulars
Apr 11, 2007
162
5
Home IPs are never visible in traceroutes. The first IP will be of the default gateway of your network connection.
 

merc782

Regular
Regulars
Jun 27, 2005
410
2
you can just ping transit router ip and say the routing is bad, these router IPs are not announced in all bgp sessions, so ping to middle routers will be bad

C:\>tracert -w 600 a.gtld-servers.net

Tracing route to a.gtld-servers.net [192.5.6.30]
over a maximum of 30 hops:


1 1 ms 1 ms 1 ms 192.168.1.1
2 6 ms 6 ms 18 ms 117.195.192.1
3 6 ms 6 ms 6 ms 218.248.164.202
4 25 ms 25 ms 26 ms 218.248.255.118
5 26 ms 26 ms 26 ms 115.113.128.17.static-mumbai.vsnl.net.in [115.113.128.17]
6 * 222 ms 223 ms ix-0-100.tcore1.MLV-Mumbai.as6453.net [180.87.38.5]
7 * 231 ms 222 ms if-2-2.tcore2.MLV-Mumbai.as6453.net [180.87.38.2]
8 * 65 ms 167 ms if-6-2.tcore1.L78-London.as6453.net [80.231.130.5]
9 * * * Request timed out.
10 * 256 ms 224 ms xe-1-1-0.r2.bb-fo.lon3.vrsn.net [195.66.225.46]
11 * 252 ms 223 ms 199.16.94.205
12 * 225 ms 225 ms xe-1-2-0.r1.bb-fo.nyc3.vrsn.net [199.16.94.13]
13 * * 230 ms xe-2-0-0.r1.bb-fo.iad3.vrsn.net [199.16.94.6]
14 * * 318 ms xe-1-2-0.r1.bb-fo.mia1.vrsn.net [199.16.94.90]
15 * 297 ms * xe-0-2-0.r2.bb-fo.mia1.vrsn.net [199.16.94.98]
16 * * 286 ms tengigabitethernet2-2.r2.edge-fo.mia1.vrsn.net [199.16.95.90]
17 * * 297 ms R1-V24-162.EDGE-FO.MIA1.VERISIGN.COM [199.7.51.162]
18 284 ms * 284 ms a.gtld-servers.net [192.5.6.30]