Configuring Linksys ADSL modem with Airtel Broadband

scrm3r

Newbie
[OP]
Sep 5, 2011
9
0
I myself have trouble setting up my linksys modem/router for airtel broadband. I used their standard modem for connection and my modem/router in only wifi mode. It was not an efficient one but atleast it worked. Finally i found out how to use your modem/router with airtel broadband.

Please note that the following step are for adsl modem/router not for wifi routers

The following steps will guide you :

1. Reset your Linksys router to factory defaults.

2. Choose Encapsulation type to RFC2516 PPPoE

3. Auto-detect : Disable and VC values 1 and 32 for Airtel.

4. DSL Modulation : G.dmt (This is a must for airtel otherwise it will not work).

5. Give your username and password.

6. Rest everything let it be set to default value, save the settings.

7. Check Status -> DSL Connection Status : Should show connected. Or else click on Connect.

Enjoy Internet Connection
 

xyx2000

Regulars
Regulars
Oct 21, 2005
2,665
314
4. DSL Modulation : G.dmt (This is a must for airtel otherwise it will not work).

This is not true , if your connection only works with g,dmt and becomes unstable with adsl2 then there is something wrong with your line. Modulation should be set to Auto.
 

scrm3r

Newbie
[OP]
Sep 5, 2011
9
0
I have tried other modulation, it simply doesn't connect even in Auto mode. Only after trying G.dmt it works.
 


xyx2000

Regulars
Regulars
Oct 21, 2005
2,665
314
In auto mode it should automatically select G.DMT if adsl2 or other mode is unstable
 

anant.del

Addicts
Regulars
Jan 2, 2010
8,172
395
try using the automatic config..it should have some software which does it on its own..I think
 

scrm3r

Newbie
[OP]
Sep 5, 2011
9
0
In auto mode it should automatically select G.DMT if adsl2 or other mode is unstable

I know. It even baffles me. Auto mode should always work right. It is called Auto for a reason. But in Status page it remains disconnected. Only when i manually set it to G.Dmt then only it works. Weird but true.

try using the automatic config..it should have some software which does it on its own..I think

Automatic config doesn't work. If you can suggest any other solution I would be glad. I fought with this for almost 4-5 months. Even the Airtel guy wasn't able to do anything. I was using my ASDL2+ modem with Beetel modem in a weird master-slave configuration. Finally i found this solution by accident and wanted to share it with people having similar problems.