Need help with a 'double NAT' issue

artisan

Member
[OP]
Dec 1, 2017
9
0
My BSNL FTTH modem config is:

GPON ONT (Alphion)
Internet Connection Type: PPPoE
Local IP: 192.168.1.251
Subnet: 255.255.255.0
DHCP Server: Enabled
Starting IP: 192.168.1.1
Max number of DHCP users: 1
SNTP State: Disabled
Port Forwarding: None
Firewall:
DMZ: Enabled
DMZ Host: 192.168.1.1
UPnP: Disabled

My wireless router config is:

D-Link DIR-615
LAN IP: 192.168.0.1
Subnet mask: 255.255.255.0
DHCP Server: Disabled
WAN Access type: DHCP Client
MAC Cloning: Default / Not cloned

However, despite the DMZ'ing above, I'm facing a double NAT issue.

The WAN configuration status on my DIR-615 wireless router is:
Interface: WAN
Protocol: DHCP
IP address: 192.168.1.1
Gateway: 192.168.1.251
Status: Link Up (DHCP Client)

I understand that a correct configuration should result in getting the ISP-assigned dynamic IP as the WAN address of the router.

How can I resolve double NAT?
 

artisan

Member
[OP]
Dec 1, 2017
9
0
I'm unfamiliar with ngrok. How do I run this considering the configurations I currently have?

Isn't there anything I can do in my router's settings to avoid double NAT?

There is no bridge mode in the ONT settings. As a matter of fact the entire ONT configuration page looks stripped down and restricted.