Possible to use the SIP/Voip from voice on FTTH with Freepbx or something similar?

goodyet

Newbie
Messages
5
I solved the issue. Siproxd was sending UDP packets via the WAN default gateway (INTERNET). Previously I had a static route to BSNLs VoIP network. I removed the default route to the Internet and made the VoIP gateway as the default gateway.

Also, I could make the VPN work by adding a specific/static route to my VPN server. But I can't reach whole of the internet from my pi. I may have to create two separate routing tables. Happy that VoIP works. Latency is pretty bad. Nothing can be done about it. I'm on a different carrier on my phone.
 

varkey

Active Member
Messages
981
Thanks for the update @goodyet, I had it working with a static route to the VOIP network. I wonder why it takes the default route 🤔Perhaps you need to enable NAT for that interface?

I had got it working with a similar setup (I use ZeroTier for remote connectivity, VPN is over kill, might be useful for you too) and never had route issue. Although I made some firewall change later which broke the VOIP stuff, haven't had the time to get that fixed yet.
 

goodyet

Newbie
Messages
5
NAT isn't required because BSNLs VoIP servers are on private ip's. I read somewhere that VoIP servers/proxies tend to ignore static routes and use default gateways. I'm yet to get siproxd work on static route. I'll continue to find a way out of this.
 


varkey

Active Member
Messages
981
Well, if BSNL's VoIP server sees traffic from an internal private IP address how is it going to send the return traffic back to you? It wouldn't know how to send it back cause yours would be from an unroutable IP address or atleast BSNL wouldn't be aware of the route.

So you definitely need NAT, and any traffic going to the VoIP server needs to use the 10.x.x.x IP address allotted to you as the source.

I definitely got it working with a static route so it's something in your configuration.
 

ChrisM

Member
Messages
208
@varkey after setting up SIP/VOIP do we need to use the same BSNL wifi to make/receive calls? or we can receive anywhere using any internet in a different city/place?
 

varkey

Active Member
Messages
981
@ChrisM You need to use the same BSNL connection, if you need to use it from a different location, you'd need some mechanism to access your home network from elsewhere (VPN, ZeroTier etc)
 


abhi5130

New Member
Messages
2
Hello All,

I have got a new BSNL FTTH connection and that has been installed and activated, Voice and Data works perfectly fine using Syrotech ONU (Wi-Fi, POT, 2 LAN). Now what I am trying to configure or rather trying to use my Grandstream GXP1625 IP Phone directly instead of the traditional analog phone. I have tried few configuration as mentioned earlier in the thread but no go. Can someone please summarize the entire settings on how to get the BSNL Voice work on a grandstream phone directly.
TIA

Regards,
Abhijit
 

varkey

Active Member
Messages
981
@abhi5130 To summarise

1. Setup VoIP wan profile in bridge mode and bind it to a different ethernet port.
2. You'd need to configure your VoIP phone WAN interface with the VoIP IP address details (you'd need to do this prior to connecting the cable from the ONT or would need to use the UI within the phone to configure), similarly pre-configure the SIP details too.
3. Connect the cable from the ONT.

In this config you wouldn't be able to access the config user interface though.
 

abhi5130

New Member
Messages
2
Thanks for your reply @varkey was expecting from you.

As I have read thru the entire thread here, I have tried all the steps mentioned above but no go. I am outside right now, I will share the screenshot of the device settings onu and ipphone gxp 1625 and syrotech onu later.
 

varkey

Active Member
Messages
981
Well, if BSNL's VoIP server sees traffic from an internal private IP address how is it going to send the return traffic back to you? It wouldn't know how to send it back cause yours would be from an unroutable IP address or atleast BSNL wouldn't be aware of the route.

So you definitely need NAT, and any traffic going to the VoIP server needs to use the 10.x.x.x IP address allotted to you as the source.

I definitely got it working with a static route so it's something in your configuration.
Looks like BSNL made some change recently so now it requires one more static route entry for traffic to 10.191.55.68, so I just added a static route for 10.191.0.0/16 to go through the VOIP interface. (A /16 is too much, but then I thought what if BSNL changes the IP address or something, anyway I don't have anything else on that subnet so it wasn't an issue)

I was noticing intermittent voice drops and did a packet dump, could see that there are many packets coming from 10.191.55.68 through the VOIP interface but none going back, so I added the appropriate routes and things are back to working.
 

Top