Audio Delay/Lip Sync Issue with HD Channels using ARC.


I recently upgraded my HTS to Sony BDVE3200 which supports ARC(Audio Return Channel).
I am using Tata sky HD STB since 5 years.
When I select Dolby Digital/Plus audio in tata sky setting, I get a slight delay(around 25-50ms) in audio.
This happens when I use my HTS to listen audio from tata sky using ARC and if I use TV Speaker it works well.
When I chose PCM output it works with no delay but there is no surround as its stereo audio.
My STB doesnt have Optical audio output and only have HDMI and normal rca (red white) output port.

Right now my setup looks like this

Tata SKY (HDMI) -> Bravia -> ARC -> HTS(HDMI)
So audio is routed from TV To HTS using HDMI ARC. I get decent surround and bass but the delay is irritating.
I would have tried to use directly the Optical audio from tata sky to HTS but unfortunately my STB lacks that port and only option to get DD Audio is using HDMI ARC feature.
This is mostly with movie channels like Star Gold,Movies now, HBO etc.
SD Channels works well(as they dont use DD audio may be ?).

I tried setting audio delay from my HTS but it can only add a delay and not subtract ( it can go for 0-200 ms but not in negative side)
According to my observation if my audio is set to -25 to -50 ms, it will resolve the issue but there is no way to set this at my end.

I contacted tata sky and they said this issue is from broadcaster end and might get fixed, but its more than 3 days and it remains.
They told me that they can send a technician but I refused as I thought I might fix it by doing some tweaks.

So what I want to confirm is -

  1. Anyone else facing this issue with ARC ?
  2. Does HD Channel audio lags if you use HTS (using arc or optical)
  3. Can anyone confirm if they use Optical audio from STB to HTS they get synced audio ?

If I replace my STB, will it solve my problem ? Pls HELP !



1. It can and it does !
Tested myself with amazon prime and Pendrive.

2. Audio can be delayed but my audio is already coming late so I have to make it in -XX ms for sync fix, but there is no setting for that.

Similar threads