How I fixed my BSNL WA3002G4 Wireless Modem + Router Issue (Firmware update)


A few days back, my BSNL Wireless Modem + Router stopped working (Model - WA3002G4 UTSTARCOM). The DSL and internet lights were not on. When I called up BSNL toll-free line, they sent a lineman to investigate.

The lineman investigated and played with router configuration ( also. Finally, he announced that there is no problem is line. The router is not working and I should buy another one (his words - "Sir, no guarantee for chinese products. Use and Throw") I went through some of the posts in this forum and requested BSNL to update firmware but they said that they are not responsible. It is a modem/router problem so they can't do anything.

I followed some advice from this forum and decided to "Reset" the modem. It complicated the matters further because after reset, I was not even able to open the router configuration page in browser to update the settings. While I was able to ping, it was not opening in the browser.

With my limited technical knowledge, I tried searching for suitable firmware. I did find firmware links on some of the posts in this forum but couldn't trust them because they were hosted on public sites by unknown people. Finally, I checked the BSNL Motive Website where one BSNL Self-Care software is listed (this is the link -

While the usual setup is pretty buggy and fails at every instance (even triggers Antivirus and firewall warnings), the required firmware updater utility is located in one little folder in this zip file (path in the folder - \MotiveActivation\Setup\WorkFlow\GUI\firmware\UT-EXE\updatetool). I copied the entire folder separately (contains one .exe file, 2 .ep files, and one .ini file). I then opened a command prompt and navigated to this folder.

I ran the exe file several times from command prompt, and it didn't do anything except throw Windows Firewall warning message. I disabled the Windows and other firewall and then ran the utility again. And, it worked. I restarted the modem and was able to access the router configuration page (

My WA3002G4 modem+router is working now and I am posting this message from this connection. Thankfully, I decided to try my hand (and not just follow BSNL advice of throwing this modem out).


Hi,I am facing exactly the same problem from last night.Could you please help me step by step? I am not that technical like you. Your guidance will save me buying new modem.Need your help.Thanks.