Beetel 450TC1 DDNS / port fwd issues


Airtel 4mbps
I upgraded my 4 years old Airtel home999 plan to 4Mbps turbo30 and since upgrade my Netgear 834G started disconnecting frequently. Tried newer Netgear DGN2200 too but that also gave frequent disconnections. Then my Airtel guy gave me Beetel 450TC1 which works flawlessly. So after much testing of over 5 days I finally settled for new Beetel 450TC1.Now I had been easily using DDNS and port forwarding port80 to my Desktop as I run XAMPP and its my test server. But ever since router change I'm not able to setup Beetel 450TC1 correctly. I also upgraded to “TM4-0Q-020(With-Without CAS)” firmware but it didn’t help.Issues I’m having:1. Can’t find where I can set Static DHCP to always assign a fixed IP to a certain MACID, necessary so I can port forward to that IP2. It has DDNS setting but when I give my login/pass, it doesn’t login to DynDns servers. I can see router log that it fails to authenticate. Don’t know what is wrong3. I’ve setup virtual server for port 80 to my desktop’s IP but putting my 122.x.x.x. IP still opens router’s login page. How do I disable remote loging outside LAN and enable portforward properlyI’m an experienced networking engineer, and have configured these on 100s of routers before. I just want to share some ideas who are using this ADSL Router and know if such settings are working for them ?