Problem Downloading files

Hello I have BSNL broadband, When i download some file they stop at a particular percentage like 45% and whenever i'll download it at whatever condition that file will stop downloading at 45%. First I thought it might be the problem of my PC but now I have 1 laptop and 1 android mobile, and the problem still persists on them also. I tried to contact the local BSNL office for finding the solution of this problem but he said there is no solution to this problem you'll have to download all that files from another network. I am very frustrated by this problem coz it happens to me most of the time, Please help me in this matter :(PS: those files get downloaded by my friends broadband network


Incoherent Poster
Gurgaon | Mumbai
What protocol are you using to download the file ? http, FTP or bittorrent. Also, assuming that you're using http, are downloading from the same file host each time ? Also, does your friend too have bsnl ?
I get problem while downloading through http, and when my friend downloads it and send me that file through gmail, then that file gets successfully downloaded without any problem. I get this problem even downloading quicktime from Apple's site and latest driver from nvidia's site, infact i have never been able to download those file, i ask my friend to download them and send me as mail.PS torrent never gave me problem like that, and yes my friend to have BSNL broadband


Mention modem model/make/number.Check Under management Access control. May have to change MTU value ( usually seen in WAN page )feedback.
I dont think its modem problem because i tried downloading the file with my friend's modem (one who can download files without problem) by my network, but the same problem persists. BTW my modem number is UT300R2U


it might be the problem of my PC but now I have 1 laptop and
1 android mobile, and the problem still persists on them also.
Which wifi router used ?surfing in wifi mode ok in laptop ?
Check your modem UT300R2u in friend's broadband connection.
and confirm Modem needs no tweaks.
Check as told earlier Management Access control .
Check all boxes. WAN side.
Since you say Modem of friend with your system was also
not working Computer or Firewall settings to be checked.
Result of 001 will confirm this.
From computer:
START run type cmd Ok
New window
Type Iipconfig /all
Copy/Paste data for LAN only.
If you tested in PPPoE mode ( userid/pw stored in modem)
change over to "Dialer" mode ( "bridged" in WAN page )
or visa versa. Use only the modem. No wifi router.
Try tcp/ip optimizer from :: The Broadband Guide
Select optimal values.

Feedback item wise. : result +ve - ve.

I checked all boxes. WAN side in Management Access control and save/rebot my modem but the problem still persists. and sorry i didnt understood what are you asking in last line


000 >> I use Netgear N150 wireless router

001>> I'll take my modem to his house later,

002>> I checked all boxes. WAN side in Management Access control and save/rebot my modem but the problem still persists.

003>> My mobile and laptop doesnt have any firewall, so i think i might not be it, BTW i tried downloading files by shutting down my zone alarm but that didnt solved my problem

Ethernet adapter LAN:
Connection-specific DNS Suffix
Description......Atheros L1 Gigabit Ethernet 10/100/100Base-T Controller
Physical address... 00-1B-FC-2C-5E-EE
DHCP Enabled.. yes
Autoconfig Enabled... yes
Link-local IPv6 address... fe80::183c.f88:e7bd.71ad%11
IPv4 Address....
subnet mask .....
default gateway...
DHCP server
DHCPv6 IAID.... 23488188
DNS servers...
NetBIOS over Tcpip... enabled


Oh crap TCPOptimizer.exe download got stuck at 382KB of 644KB from there site and from

and cnet_TCPOptimizer_exe.exe from got stuck at 410kb of 443kb :(


i tried to download the file from, ,CHIP Online (German) and their site, download always get stuck at 382KB of 644KB. This is the main problem i am facing, the particular file will never get beyond that particular percentage no matter whatever i try :(


005 no reply.
It is the tested application for speed problems etc
Try in SAFE MODE with internet connection.
Try without any download Manager.
Enter DNS in TCp/IP properties page and
( also in modem dns page )

Feedback item wise. : result +ve - ve.
usually members do not give feedback when tweaks do not work
or if successful no feedback resulting in thread "hanging !"
005>> how to change for PPPoE to Dailer mode?

006>>i cant run TCPoptimizer coz i can't download it (sorry typing mistake)

007>> -ve I tried downloading in safe mode but it didnt work

008>> -ve i always download file without any download manager


My friend told me that after connecting his modem to my network.. his internet connection is giving problem, he says that he get connected to internet but when he opens any site on browser it gives "DNS look up failed".


when i ran the Diagnostics i got this result is it normal?
005>> how to change from PPPoE mode to dailer mode?

006>> i cant run TCP optimizer coz i cant download it


008>> -ve i never use download manager


i ran diagnostics and got this result is this normal?