JIO FIBER 5Ghz not working on my Desktop

Messages
11
Location
Mumbai
ISP
JIO Fiber
I have JIO Fiber latest router installed at my home Model No. JCOW401. On my TV and my mobiles it shows 5Ghz network and connects to it and I get good speed too.
On my desktop unit I have Windows 10 64 Bit (Legal copy of windows) and I have installed 5ghz compatible TP-Link AC600 High Gain Wireless Dual Band USB Adapter.

The problem is that on my desktop unit it does not show 5Ghz network and only shows 2Ghhz network with a speed of only 50Mbps when tested. I had called their customer care but they refused to take a complaint.

Can someone help ?
Regards (Gagan Sood)
 

JB701

Амогус Сус
Messages
1,723
Location
Delhi
ISP
TriplePlay/Excitel
try installing the latest drivers for the wifi adapter.

Don't know the exact model you are running but i think you have this:


Can you link the page you brought it from?
 
Messages
11
Location
Mumbai
ISP
JIO Fiber
Downloaded the drivers from the link you provided. But the problem still is same. It is not detecting 5G network. Only detecting 2G network.
 
Messages
31
Location
Mumbai
ISP
Joister; Jio
  1. Search "cmd" in the Start Menu.
  2. Type "netsh wlan show drivers" in the Command Prompt & Press Enter.
  3. Look for the "Radio types supported" section.
 


JB701

Амогус Сус
Messages
1,723
Location
Delhi
ISP
TriplePlay/Excitel
Right Click on "TP-Link Wireless USB Adapter"

Click on "Properties'

Click on Driver tab and also take screenshot of that box

Click on Details tab, Select 'Hardware ID' property and copy/paste the first hardware id line here.