How to use Nokia 2425G router in bridge mode?

Messages
14
Location
Thane
ISP
Airtel
Hi,

Total networking noob here and receieved airtel connection just couple of days back so I am still exploring.

Airtel provided Nokia G-2425G GPON router however I would like to use my Mi 3G router running on OpenWRT as my main and use the ISP provided router as just a gateway/bridge mode with wired LAN cable.

I noticed that there is "Connection mode" in Network > WAN page but it is disabled for me, not able to change or modify any fields. Source


There is an option to Save/Delete WAN connection on same page, but I do not know my PPPoE password.

Also, once I configure this to run on Bridge mode what do I need to do on my main router?

I am totally lost here on how to configure this setting or what tutorial to follow.
 
Messages
14
Location
Thane
ISP
Airtel
Because all major isps are now managing routers remotely. Excitel and Jio don't give bridge mode control to users at all. Airtel is known to do it if you manage to contact the right person.
Call me naive but how are they able to access my router which is on local lan and no port is open for them to access the router. Also, how to revoke the access?
 
Upvote 0

Sushubh

Be nice pliss
Staff member
Messages
379,781
Location
Gurugram
ISP
Excitel
Airtel
how did the installation guy configure your airtel router? for me it was all from backend. i was given a page where i entered my choice of wifi name and password. rest was all configured by airtel at their end.

 
Upvote 0
Messages
14
Location
Thane
ISP
Airtel
Unfortunately I was not home when configuration happened so i am basically clueless. I dont even know my pppoe password, anyway to find out or change it? airtel support gave me 3 passwords but none work
 
Upvote 0

igloo

Not just Internet.
Messages
3,692
Location
New Delhi
ISP
Exictel Fiber+ Airtel xstream
One can see and change router wifi name n password from xstream(not myairtel) app. even guest wifi.
Can reboot router & check connected devices too.
All this from anywhere no need to be connect to airtel wifi.
 
Upvote 0
Messages
551
Location
Ludhiana, PB
ISP
Jio Fiber, Airtel Xtreme
Hey thank you this approach looks good to me. But I am trying to understand why do we need to have PPPoE authentication on both the routers? By default it will happen on Nokia which cannot be disabled or removed then why another PPPoE mode on Mi router? (I am having hard time finding password for my account which is not my account number)

Would you suggest I have pppoe only on nokia and use Mi for wifi and all device connect to it? Also, where and how do I need to change the VLan ID to 100?

Thats the way how Airtel Bridge mode is setup. On a positive side, both the routers would Invidually connect with their seprate IP Addresses. Incase, you don't wanna use the Bridge mode in MI Router, you could use that as an access point instead. The Vlan ID should be under where you setup the PPOE connection. You might need to check it under Advanced Settings under your Mi Router. If you aren't able to find the VLAN ID, the bridge mode might still work as i have seen someone who couldn't find it and it works for him. AFAIK, the passowrd is always the account number. If that doesn't work, ask the Local engineer to change it.
 


Upvote 0
Messages
14
Location
Thane
ISP
Airtel
@yougotmehere I tried following the steps you told me but still my Mi router would not connect I keep getting error in PPPoE connection. I confirmed my password in indeed account number via router logs.

LAN : Source


WAN : Source


Port Connections : Source


VLAN ID : Source


Interfaces : Source

My config file if that helps.

Code:
[email protected]:~# vi /etc/config/network
config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option mtu '1506'
        option ipaddr '192.168.31.1'

config device 'lan_eth0_1_dev'
        option name 'eth0.1'
        option macaddr '*****'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'pppoe'
        option ipv6 'auto'
        option username '******'
        option password '*******'
        option delegate '0'
        option mtu '1506'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '6t 3 2'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '6t 1'
        option vid '2'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '1t'
        option vid '100'
 
Last edited:
Upvote 0
Messages
551
Location
Ludhiana, PB
ISP
Jio Fiber, Airtel Xtreme
@ConfusedUser I have seen your SS's and i beleive they are good wrt to the Airtel modem. Here are the things that you can try on your MI Router.
1. Not sure if MTU size has any direct correlation with the login but you need to change it to 1492 instead of 1506.
2. Airtel doesn't support IPv6 for now. Change it to IPv4 where ever applicable and disable IPv6
2. Enable VLAD ID : 100 on all the Lan and WAN ports except Wifi on MI Router
3. If the above doesn't work, try swaping the Lan4 port on Airtel modem with Lan1 port and set it to Bridge mode. For some the bridge mode works on that port.
4. Hope you didn't copy the PPOE login password in the MI Router and rather typed it?
5. If all of the above doesn't work, i suspect something to be wrong with your OpenWRT firmware. Try borrowing an another router with stock firmware to test.
 
Upvote 0