How to use Nokia 2425G router in bridge mode?

Messages
8
Location
Thane
ISP
Airtel
Hi,

Total networking noob here and receieved airtel connection just couple of days back so I am still exploring.

Airtel provided Nokia G-2425G GPON router however I would like to use my Mi 3G router running on OpenWRT as my main and use the ISP provided router as just a gateway/bridge mode with wired LAN cable.

I noticed that there is "Connection mode" in Network > WAN page but it is disabled for me, not able to change or modify any fields. Source


There is an option to Save/Delete WAN connection on same page, but I do not know my PPPoE password.

Also, once I configure this to run on Bridge mode what do I need to do on my main router?

I am totally lost here on how to configure this setting or what tutorial to follow.
 

Sushubh

Be nice pliss
Staff member
Messages
379,853
Location
Gurugram
ISP
Excitel
Airtel
Contact airtel support and ask them to enable bridge mode on your connection. It's disabled by default iirc.

I guess config details also they can provide.
 
Upvote 0
Messages
550
Location
Ludhiana, PB
ISP
Jio Fiber, Airtel Xtreme
@ConfusedUser Go to Airtel Modem settings >> LAN Settings and change the mode of Lan 4 to Bridge Mode from Route Mode. Reboot the Airtel Modem. Connect you MI WAN port to Airtel Lan port 4. Configure the MI router in PPOE Mode. Fill in your airtel user name (copy that from Airtel modem) and password (Airtel Account No). Set the IP and DNS to fetch automatically. Lastly change the VLan ID to 100. Reboot and you'll be in the bridge mode. No need to fiddle out with the WAN profile or contact the Support team
 
Upvote 0
Messages
8
Location
Thane
ISP
Airtel
Thanks tried reaching to support. They are clueless got escalated to technical team, even he was not able to help and raised a ticket.

But when we are able to logging into the router as an admin should we be able to change everything how are they still controlling few configurations? I still don't understand why those pages are disabled for me.
 
Upvote 0

Sushubh

Be nice pliss
Staff member
Messages
379,853
Location
Gurugram
ISP
Excitel
Airtel
Because all major isps are now managing routers remotely. Excitel and Jio don't give bridge mode control to users at all. Airtel is known to do it if you manage to contact the right person.
 
Upvote 0
Messages
15
Location
Pune
ISP
Airtel
@ConfusedUser contact Airtel Support and they will enable bridge mode. No amount of hacking worked for me. My connection was installed last month. The enable bridge mode on LAN port, I think it's P4. The PON acts like a normal router + a bridge. TBH its like having two connections because the PON gets a diff IP and my wifi router another one. :D
 
Upvote 0
Messages
8
Location
Thane
ISP
Airtel
@ConfusedUser Go to Airtel Modem settings >> LAN Settings and change the mode of Lan 4 to Bridge Mode from Route Mode. Reboot the Airtel Modem. Connect you MI WAN port to Airtel Lan port 4. Configure the MI router in PPOE Mode. Fill in your airtel user name (copy that from Airtel modem) and password (Airtel Account No). Set the IP and DNS to fetch automatically. Lastly change the VLan ID to 100. Reboot and you'll be in the bridge mode. No need to fiddle out with the WAN profile or contact the Support team

Hey thank you this approach looks good to me. But I am trying to understand why do we need to have PPPoE authentication on both the routers? By default it will happen on Nokia which cannot be disabled or removed then why another PPPoE mode on Mi router? (I am having hard time finding password for my account which is not my account number)

Would you suggest I have pppoe only on nokia and use Mi for wifi and all device connect to it? Also, where and how do I need to change the VLan ID to 100?
 
Upvote 0