Internet is fast, but wifi speed is slow

Messages
861
Location
Karnataka
ISP
▪️ BSNL Fiber(Direct)
▪️ (Jio Airtel) 4G
Bridge is the one you should try. You will have to put on Bridge if you get a NAT issue at a later point of time. So do it when you are configuring it , you know. Its not very difficult

You can try posting screenshots and ask help if you get stuck at any method
 
Messages
60
Location
NA
ISP
Bsnl
Thanks @shashankb

As far as I learned, I have to change ONT to bridge mode and then in router settings, select PPPoE and give credentials.

Any other settings needed? Do I gave to change DHCP settings?

Please let me know.

@varkey .. Can you add your inputs in this?

Thanks
 
Messages
861
Location
Karnataka
ISP
▪️ BSNL Fiber(Direct)
▪️ (Jio Airtel) 4G
Nothing much to change after you get your everything working and internet on your router , just turn off Wifi on your ONT

This is related to Wifi and not the Internet configuration and should be done in your router(not ONT). Use WPA2/PSK as Encryption and turn off WPS as it can lead to Wifi getting compromised
 
Messages
60
Location
NA
ISP
Bsnl
The router TP-Link Archer C80 has arrived and set it up in bridge mode.

The internet was connecting. So there is no issues in setup. Voila..

But very much disappointed with the WIFI range Archer gives. Its the same as my old router Huawei. No Improvements.

Also the speed shows less now. Also latency increased, from around 20 to 140 ishh. I am getting around 80 Mbps now in LAN but previously I get 100+ always.

Connecting with bridge mode increase latency or decrease speed? I am using LAN3 port.

The new modem not giving any range improvements and gives speed issues.

There are two WIFI SSID's one for 2.4 ghz band the other for 5 ghz Band. need to manually select which SSID to connect in wifi client.

What's your opinion guys.

Thanks
 


JB701

CCP ate my homework
Messages
1,508
Location
Delhi
ISP
TriplePlay/Excitel
I think there might be something wrong with configuration.
I assume you connected by wire to your MAC

What is your link speed?

Also,
go to Router UI:
1. Click on Network Map
2. Click on router logo thingy
3. Scroll down and youll see "Ethernet Status". Send pic of that
 
Last edited: