IPv6 setup on your router behind JIO router

bhojv74

Regular
Messages
627
ISP
Airtel
Hi,

I read in other posts that IPv6 on the JIO router is accessible from outside the network. I'm interested to workout a setting on my own router (ER-X) which is connected to JIO router so that my machines get IPv6 PD addresses. I tried few setting but it did not work. If anyone has managed to set their routers (any model) behind JIO router, can pls share their settings, I can then replicate the same on the ER-X.

On the JIO router I get:
WAN: 2405:201:yy:xx:zz:aa:bb:1fba/128
LAN: 2405:201:yy:aa::bb:1d01/64
2405:201:yy:bb:xx:yy:zz:1198/64

thanks,
 
Messages
377
Location
Rohtak
ISP
Jio Fiber
Is JioFiber WAN IPv6 public? When I go to sites like whatsmyip, it shows a different IPv6 address than the WAN IPv6 in Jio router. Am I missing something?
 
Messages
447
Location
Delhi
ISP
Excitel
Will need more details. Is your ER-X getting a ipv6 address (it should if it is directly connected to the jio router as a device), can you access/ping/dig ipv6 based services from the ER-X cmdline? and what all have you tried?

EDIT: Does the jio router support DHCPv6, if not your ER-X will only get a single IPv6 address and won't get the /64 subnet assigned to it.
 

bhojv74

Regular
Messages
627
ISP
Airtel
@achaudhary997 The JIO router has IPv6 IPs and seems to support it. But what I'm reading is that you need atleast /60 prefix so that you can use DHCP PD. I tried below config which does not fetch any Ipv6 on any of the interfaces:

set interfaces ethernet eth1 dhcpv6-pd pd 0
set interfaces ethernet eth1 dhcpv6-pd pd 0 prefix-length 60
set interfaces ethernet eth1 dhcpv6-pd rapid-commit enable
set interfaces ethernet eth1 dhcpv6-pd pd 0 interface switch0.1
set interfaces ethernet eth1 dhcpv6-pd pd 0 interface switch0.1 host-address ::1
set interfaces ethernet eth1 dhcpv6-pd pd 0 interface switch0.1 prefix-id :1
set interfaces ethernet eth1 dhcpv6-pd pd 0 interface switch0.1 service slaac
set interfaces switch switch0 vif 1 ipv6 router-advert prefix ::/64
set interfaces switch switch0 vif 1 ipv6 router-advert managed-flag true

When changing line 2 to 64 prefix, the router is not letting me commit changes and gives below error:

ER-X prefix-id must be less than :: for prefix /64
 
Messages
447
Location
Delhi
ISP
Excitel
The error is at the line with prefix-id, try removing : (colon) and just keeping the integer.
 


Messages
90
Location
Navi Mumbai
ISP
Jio Fiber
If I'm not mistaken - the router itself has a /64, and so it can assign IPs to other devices connected to it directly, but cannot provision another /64 to your 2nd router - and have devices connected to it receive individual public IPv6.

Effectively - it thinks your router is the target device. I am also looking for a solution to this, currently my pfSense box has a /64 IPv6 assigned, and I am trying to see if I can make this split or served across different devices connected to it.
 

bhojv74

Regular
Messages
627
ISP
Airtel
The error is at the line with prefix-id, try removing : (colon) and just keeping the integer.

This gave another error:

ubnt@HomeUbnt# set interfaces switch switch0 vif 1 ipv6 router-advert prefix /64
"/64" is not a valid value of type "ipv6net"
Value validation failed
Set failed
 
Messages
447
Location
Delhi
ISP
Excitel
Not sure what that is as I am trying to help you blindly as of now.
Another issue that you will run into is that the jio router will be giving out IP addresses via slaac (this is a guess as this is what most consumer routers do) and not dhcpv6, so it won't be replying properly to the erx requests.