Jio WiFi calling on Airtel Broadband

Messages
55
Location
NA
ISP
Spectra
I used to have Spectra and Jio WiFi calling on the iPhone used to be seamless. Switched to VoWifi as soon as it connected to the Wireless network. With Airtel, this is spotty. Sometimes it connects, sometimes it doesn't. Rebooting the phone or the router doesn't seem to help.

However, if I switch to Cloudfare DNS from Airtel's DNS on my router, VoWifi is perfect again. Has anyone else observed this? Is Airtel deliberately blocking Jio VoWifi?
 
Messages
241
Location
Coimbatore
ISP
Airconnect | Limras Eronet | Airtel & Vi
@SVK yes, billing is same as VoLTE, only difference is in VoWifi your call will be routed through your BB from last mile instead of using Jio's network
 
Upvote 0

pswapneel

Swapneel
Messages
87
Location
NA
ISP
AS24186
I did some digging, so it appears the DNS name vowifi.jio.com resolves differently based on the source IP address of the resolver (or maybe they do make use of the EDNS-Client-Subnet mechanism also, I did not test that).

View attachment 1891

So from India it resolves to 49.44.59.38 & 49.44.59.36, but from anywhere else it resolves to 49.45.63.2 & 49.45.63.1. The above image is from OpenDNS cache check (OpenDNS: Cloud-Delivered Security Enforcement and Intelligence) where you can check how the name resolves from various geographies.

So my guess is, they have this mechanism probably to support VoWiFi during international roaming. When outside India, you get redirected to a different endpoint, and the VoWiFi is enabled only when the required plan or addon is active.

The setup is a bit weird, if I ask ns1.jio.com which is one of the nameservers for jio.com, it says go ask ns1/2.vowifi.jio.com. But they are missing the DNS records for ns1.vowifi.jio.com and ns2.vowifi.jio.com, but they do send the glue records, so it does work.

Code:
(⎈ |docker-desktop:default)➜  ~ dig vowifi.jio.com @ns1.jio.com.

; <<>> DiG 9.10.6 <<>> vowifi.jio.com @ns1.jio.com.
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 3137
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 2, ADDITIONAL: 3
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;vowifi.jio.com.            IN    A

;; AUTHORITY SECTION:
vowifi.jio.com.        3600    IN    NS    ns1.vowifi.jio.com.
vowifi.jio.com.        3600    IN    NS    ns2.vowifi.jio.com.

;; ADDITIONAL SECTION:
ns1.vowifi.jio.com.    3600    IN    A    49.44.59.6
ns2.vowifi.jio.com.    3600    IN    A    49.44.59.7

;; Query time: 60 msec
;; SERVER: 2405:200:1602:720::4#53(2405:200:1602:720::4)
;; WHEN: Thu May 21 11:15:07 IST 2020
;; MSG SIZE  rcvd: 111

But the issue I am facing at times is that vowifi.jio.com resolves to the international IP addresses and VoWiFi doesn't work. I do use a caching resolver, so I am trying to pinpoint the actual problem. However, I can definitely say that this isn't set up properly from Jio's perspective.

@varkey I have been looking at this issue for sometime now and running a few measurements of my mine. It appears, from every location outside India, vowifi.jio.com resolve to 49.45.63.1 and 49.45.63.2. However, from within 75 networks within India, a pattern has begun to emerge, there were considerable number of networks where vowifi.jio.com resolves to 49.45.63.1 and 49.45.63.2 & there is a local DNS resolver in the network :)

Having said that, there were also also networks which were using ISP DNS resolver or one of the cloud/quad DNS provider, where vowifi.jio.com resolved to 49.45.63.1 and 49.45.63.2. In short, the pattern isn't separating the white from the black. 75 is a small sample size to begin with.

Here is a quick question for you/anyone in this forum for whom Jio VoWiFi isn't working, from the same network, if you use your ISP DNS resolver or any of the cloud/quad DNS resolver, can you share the results of dig/nslookup here ? If you do not have access to a computer/laptop and want to share results from your phone, I recommend installing the Hurricane Electric Network Tools app

Edit - Fixed semantic errors in the comment by replacing with a strikethrough.
 
Last edited:
Upvote 0
Messages
3,051
Location
Bangalore | Ernakulam
ISP
Excitel | BSNL
@swapneelp I've been observing something similar over the last few days since my post. VoWiFi works intermittently for me.

For example, this is from Google DNS, the same query run with maybe a second or two in between. It is also interesting that the TTL is super low, like 5 seconds, which would in a way explain the varying results. Depending on the Google recursive resolver node which actually makes the query to the Jio nameservers, it might be returning different results that gets cached.

Code:
[email protected]:~# dig vowifi.jio.com @8.8.8.8 +short
49.45.63.1
49.45.63.2
[email protected]:~# dig vowifi.jio.com @8.8.8.8 +short
49.44.59.36
49.44.59.38
[email protected]:~# dig vowifi.jio.com @8.8.8.8 +short
49.45.63.2
49.45.63.1
[email protected]:~# dig vowifi.jio.com @8.8.8.8 +short
49.44.59.38
49.44.59.36
[email protected]:~# dig vowifi.jio.com @8.8.8.8 +short
49.44.59.36
49.44.59.38
[email protected]:~# dig vowifi.jio.com @8.8.8.8 +short
49.45.63.1
49.45.63.2
[email protected]:~#

1.1.1.1 seem to consistently return the same result. Same behavior with my ISP resolvers.

Code:
[email protected]:~# dig vowifi.jio.com @1.1.1.1 +short
49.44.59.38
49.44.59.36
[email protected]:~#
[email protected]:~# dig vowifi.jio.com @61.1.1.1 +short
49.44.59.38
49.44.59.36
[email protected]:~#

Clearly Jio has messed it up for reasons unknown to me. At this point, I really don't know what they are trying to achieve.
 


Upvote 0

pswapneel

Swapneel
Messages
87
Location
NA
ISP
AS24186
Ok. I am not sure why I don't see an option for 'Reply' so that I can quote your comment. So, instead, I am going to copy-paste and respond below it. Pardon the hack !

@swapneelp I've been observing something similar over the last few days since my post. VoWiFi works intermittently for me.

For example, this is from Google DNS, the same query run with maybe a second or two in between. It is also interesting that the TTL is super low, like 5 seconds, which would in a way explain the varying results. Depending on the Google recursive resolver node which actually makes the query to the Jio nameservers, it might be returning different results that gets cached.

The low TTL part is expected. I have seen similar low TTLs for destination domains of other carriers for VoWiFi. For example in the case of Airtel, in my case (depending on the region) the domain being queried is epdg.epc.mnc045.mcc404.pub.3gppnetwork.org

; <<>> DiG 9.10.6 <<>> epdg.epc.mnc045.mcc404.pub.3gppnetwork.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 30595
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;epdg.epc.mnc045.mcc404.pub.3gppnetwork.org. IN A

;; ANSWER SECTION:
epdg.epc.mnc045.mcc404.pub.3gppnetwork.org. 4 IN A 106.200.64.1

;; Query time: 53 msec
;; SERVER: 192.168.0.250#53(192.168.0.250)
;; WHEN: Sat May 30 21:02:00 IST 2020
;; MSG SIZE rcvd: 87

Btw, for Jio, they also have the standardised domain epdg.epc.mnc861.mcc405.pub.3gppnetwork.org (Again, this is depending on region ). Ideally, the domain is standardised & is made up of Mobile Network Code(MNC) and Mobile Country Code(MCC). As expected, in my case the domain name resolves to 49.44.59.36 and 49.44.59.38.

; <<>> DiG 9.10.6 <<>> epdg.epc.mnc861.mcc405.pub.3gppnetwork.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 54903
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;epdg.epc.mnc861.mcc405.pub.3gppnetwork.org. IN A

;; ANSWER SECTION:
epdg.epc.mnc861.mcc405.pub.3gppnetwork.org. 5 IN A 49.44.59.36
epdg.epc.mnc861.mcc405.pub.3gppnetwork.org. 5 IN A 49.44.59.38

;; Query time: 56 msec
;; SERVER: 192.168.0.250#53(192.168.0.250)
;; WHEN: Sat May 30 21:03:59 IST 2020
;; MSG SIZE rcvd: 103

Quick question for you, if you add static DNS A records in your resolver for vowifi.jio.com to 49.44.59.36 and 49.44.59.38, does VoWiFi work in a stable fashion ?

I am going to run a few more tests in this line of thinking and see how it goes.
 
Upvote 0
Messages
3,051
Location
Bangalore | Ernakulam
ISP
Excitel | BSNL
The low TTL part is expected. I have seen similar low TTLs for destination domains of other carriers for VoWiFi. For example in the case of Airtel, in my case (depending on the region) the domain being queried is epdg.epc.mnc045.mcc404.pub.3gppnetwork.org

Ah I see. So the low TTL could be part of the VoWiFI spec? Also, I wasn't aware of this other domain being used for VoWiFi, and that could explain the intermittent issues I've been seeing. Thanks for that. 🙇‍♂️

I went through my DNS query logs and sure enough, I see repeated queries being made to epdg.epc.mnc862.mcc405.pub.3gppnetwork.org as well. This is in addition to vowifi.jio.com

And as expected Google DNS returns different results for that too.

Code:
[email protected]:~# dig epdg.epc.mnc862.mcc405.pub.3gppnetwork.org @8.8.8.8 +short
49.44.59.36
49.44.59.38
[email protected]:~# dig epdg.epc.mnc862.mcc405.pub.3gppnetwork.org @8.8.8.8 +short
49.45.63.1
49.45.63.2
[email protected]:~# dig epdg.epc.mnc862.mcc405.pub.3gppnetwork.org @8.8.8.8 +short
49.45.63.1
49.45.63.2
[email protected]:~# dig epdg.epc.mnc862.mcc405.pub.3gppnetwork.org @8.8.8.8 +short
49.45.63.1
49.45.63.2
[email protected]:~# dig epdg.epc.mnc862.mcc405.pub.3gppnetwork.org @8.8.8.8 +short
49.44.59.38
49.44.59.36
[email protected]:~#

Quick question for you, if you add static DNS A records in your resolver for vowifi.jio.com to 49.44.59.36 and 49.44.59.38, does VoWiFi work in a stable fashion ?

This is exactly what I tried, I created a record vowifi.jio.varkey.io (this points to the two correct IP addresses) and added an override for vowifi.jio.com to this name. (This was only because I use NextDNS (for now) and they don't allow multiple override records for the same name)

However doing this didn't give stability, but based on the new info from you about the 3gppnetwork.org domain, I will now conditionally forward 3gppnetwork.org to my ISP resolver or CloudFlare and see if I get stable VoWiFi.

Great info @swapneelp! 🙇‍♂️
 
Upvote 0

pswapneel

Swapneel
Messages
87
Location
NA
ISP
AS24186
Mods, can you see why I don't see the Reply option for the latest post in the thread ?

Ah I see. So the low TTL could be part of the VoWiFI spec? Also, I wasn't aware of this other domain being used for VoWiFi, and that could explain the intermittent issues I've been seeing. Thanks for that. 🙇‍♂️

Yes. If you would be interested, here is a document with the details of how DNS infrastructure should be implemented. Check the section '6.5 Delegation of sub-domains of “pub.3gppnetwork.org”'.

This is exactly what I tried, I created a record vowifi.jio.varkey.io (this points to the two correct IP addresses) and added an override for vowifi.jio.com to this name. (This was only because I use NextDNS (for now) and they don't allow multiple override records for the same name)
A suggestion and a comment for you,
1. I will test this myself with NextDNS w.r.t rewrite but I have a hunch, there a problem there. The TTL would vary. Instead, I would suggest you to rewrite natively in your DNS resolver. For that though, you will have to temporarily switch to running the resolver not as a forwarder but instead as a recursive resolver speaking to root. Many ways to do this, but this would be the ideal test configuration which will eliminate all complexities.

2. Upon logging into NextDNS, I am able to see an option 'Anonymized EDNS Client Subnet' which is turned on by default.

Screenshot 2020-05-30 at 9.41.24 PM.png


Can you turn that off & give it a whirl ? 😀

Great info @swapneelp! 🙇‍♂️
The path to going down the rabbit hole has many benefits, making friends along the way is certainly one of it :)
 
Upvote 0

Sushubh

Be nice pliss
Staff member
Messages
383,427
Location
Gurgaon
ISP
Excitel
Airtel
reply on last post in thread is hidden because people use it on every single post which means every post is quoted in the next post and it goes on and on and on and on and on and on. it adds garbage to the thread view because every post is repeated twice. and user would have to check if the quoted post is something from previous pages or just the previous post. it's just annoying. i see this behaviour on other forums all the time and i just hate it.
 
Last edited:
Upvote 0