Galaxy s10+ | Ported to Airtel | VoWiFi not working

vebk

Mr. Advocate
Messages
2,218
Location
New Delhi
ISP
Airtel 8 Mbps 'Unlimited'
Hi, I just ported to Airtel, and while normal calling, SMS, data etc seem to be working, I am unable to get VoWiFi to work. Once I put in the Airtel SIM the setting showed up for "WiFi Calling" and I have turned that on. However, neither does the VoWiFi icon show in the notification area, nor does any call work over WiFi.

Am I missing something obvious?

Things I have tried (but have not worked):
  1. Taking the SIM out, rebooting and powering off the phone, putting the SIM back (in slot 1) and turning it on again.
  2. Switching Wifi Calling off and on several times.
  3. Switching off the second SIM (Vodafone)
  4. Toggling network modes (4G/3G/2G | 3G/2G | 2G)
  5. Putting on Airplane mode and turning on WiFi. (When I try to place a call, it states that I should "Turn off Flight mode or connect to Wi-Fi to make this call" even though WiFi is connected).
  6. Used WiFi of Airtel Broadband as well as ACT Broadband (I have both).
Nothing works!
 

Sushubh

Be nice pliss
Staff member
Messages
383,427
Location
Gurgaon
ISP
Excitel
Airtel
yeah. it's possible that porting is treated differently. plus s10+ is like a year old model now. so it might get enabled in a day or two.

the problem is that airtel 3g has been shut down in delhi ncr so you are probably stuck on 2g for making and receiving calls and it does not really work well. so without volte, you are going to have a tough time.
 
Upvote 0

igloo

Not just Internet.
Messages
3,877
Location
New Delhi
ISP
Exictel Fiber+ Airtel xstream
For 2g i find voda better than airtel in Delhi.
But voda still has 3g network active.
 
Upvote 0

vebk

Mr. Advocate
Messages
2,218
Location
New Delhi
ISP
Airtel 8 Mbps 'Unlimited'
Problem solved! Highlighted this issue to Airtel Presence yesterday and woke up this morning to see VoWiFi working! A quick restart later VoLTE also working! Just got a call from their social media team explaining that they "refreshed the settings" from their end, and it should now be working. Great success!

So basically you don't need to change the SIM - just need to reach out to them to "refresh" their settings.

Also tested VoWiFi briely - what a game changer! Don't have to run to the balcony to answer calls anymore!! :)

(Though VoWiFi doesn't seem to work on Flight Mode with WiFi on).
 
Upvote 0

Sushubh

Be nice pliss
Staff member
Messages
383,427
Location
Gurgaon
ISP
Excitel
Airtel
heh. if only they did the refresh thing with me. freaks kept telling me that my device was not supported.

vowifi does work on airplane mode on ios devices.
 
Upvote 0