How to enable VoWiFi on OnePlus smartphones!

@Ameen I have op7 on android 10 and i don't have the option. So i guess it is not necessary
It has been disabled by default by OnePlus. You can enable the option using the below given steps:
1. Dial *#800#
2. Go to Oneplus logkit
3. Go to function switch
4. Check on Vowifi switch
5. Reboot your phone
6. go to settings -- wifi & internet -- sim & network
7. Turn on WIFI Calling
8. Reboot your phone

Wait few minutes you will see volte will be replaced by vo-wifi .
 
Messages
993
Location
NA
ISP
BSNL
[QUOTE]@Realme Enthusiast brand? There is none at the moment.[/QUOTE]

I meant a phone I can tinker around with, which doesn't add major obstacles intentionally.(bootloader locks etc)
PS: I request members to change from "Depressed Linus DP" What's the point when everyone has the same DP? LMAO.

It's purpose was to make you LMAO.

How is your ass rigght now? --Proctologist

Originaly @vignesh_venkatesan and @JB700 featured Linus DP which confused me a lot too, I thought lets add twist to the sauce and don the image of sexy Chad Linus

They're getting greedy

I think less greedy about money and more greedy about having an Apple-like brand image, like a solely chinese-image brand having that much glam to it.
Being a luxury brand.
(<rant> luxury are not always great somewhere here said they have an high end 1+ Lakh INR TV which doesn't have gigabit port... poor pleb enthusiast might have made a workhorse HTPC in that budget..in that budget I wouldn't even buy a TV but a projector and modify my room for cinematic experience</rant>)
It appeals to their Chinese nationalism.


For a short period of time while I had Xiaomi I like MiUI, it was quite productive for me, maybe i didn't use it that much to push it to its limits.

I personally wanted modular phones to comee to the market and we can upgrade them for a few years just like PC ...oh my fantasies ;-;
 
Last edited:

sanke3

I got banned!
Messages
312
Location
NA
ISP
MTNL FTTH
^^ Someone had tried modular phones few years ago. I remember reading it somewhere.
 
Messages
1
Location
Bangalore
ISP
BBNL
Alright guys. I did it. VoWifi activated in Airplane Mode on my OnePlus 7

Calls and SMS incoming and outgoing working on both the numbers.

UbHGfCZ.jpg


Original Guide is here. But I have simplified the process below because that guide is as confusing as it gets.
  1. Download this zip as it contains LogKit and EngineeringMode apk. Install them both on your OnePlus phone.
  2. Dial *#800# -> oneplus Logkit -> Function Switch -> enable VoLTE switch & VoWifi switch & VT switch and then reboot your phone
  3. Go to Settings -> Wifi & Internet -> Sim & network -> Sim 1 -> enable VoLTE and Wi-Fi Calling switches. Do the same for Sim 2
  4. Use the Drivers and software from below and not from the above link as the drivers mentioned in the original post do not work.
  5. Correct QPST drivers here.
  6. Correct QPST software here.
  7. Install both the QPST software and drivers with default selections during setup.
  8. Connect your phone to USB port of your PC and dial *#801#
  9. Only enable Full-port switch
  10. Open "PDC" in your QPST start menu folder, best to do by right click & "run as administrator"
  11. In the drop down menu, chose your Qualcomm device. For me it was Qualcomm HS-USB WWAN Adapter 9091 yours can be different.
  12. In the list, Right click on Germany-VoLTE-Vodafone -> SetSelectedConfig -> Sub0
  13. Again Right click on Germany-VoLTE-Vodafone -> SetSelectedConfig -> Sub1
  14. Now just select Germany-VoLTE-Vodafone and click on Activate button at the bottom.
  15. Reboot your phone.
  16. Profit?
TBH it's extremely easy

Can someone report their findings?

I see that your phone shows Airtel and Jio !. Can you tell me what are the settings for these two ?
 


Messages
31
Location
NA
ISP
Reliance Jio Gigafiber
Ok, this is interesting. I got VoWiFi in Airplane mode on OnePlus 5 running OOS 9.0.11. (I enabled VoWiFi via oneplus logkit)

These are the steps that I did for it to work, your mileage may vary,
1. Enable VoLTE, VoWiFi in sim settings and go to Homescreen
2. Enable Airplane mode from QS.
3. Go into sim settings and,
3a. Disable VoLTE and VoWiFi.
3b. Enable VoLTE and VoWiFi.
3c. Change "Calling Preference" from "Wi-Fi preferred" to "Mobile data preferred"
3d. Change "Calling Preference" from "Mobile data preferred" to "Wi-Fi preferred"
4. That's All.

In my current place, Jio signals drops very frequently while moving around the house. Hence, I have vowifi enabled.
I have a Redmi phone with another Jio sim in a place where there's a better reception and using it as HotSpot (for WFH)
This OnePlus 5 is connected to the HotSpot. Probably because its Jio network, I'm getting VoWiFi even on Airplane mode. I wish this isn't the case.
 

Attachments (DOWNLOAD AT YOUR OWN RISK)

  • Screenshot_20201013-175736.jpg
    Screenshot_20201013-175736.jpg
    71.6 KB · Views: 110