How to enable VoWiFi on OnePlus smartphones!

@Ameen I have op7 on android 10 and i don't have the option. So i guess it is not necessary
It has been disabled by default by OnePlus. You can enable the option using the below given steps:
1. Dial *#800#
2. Go to Oneplus logkit
3. Go to function switch
4. Check on Vowifi switch
5. Reboot your phone
6. go to settings -- wifi & internet -- sim & network
7. Turn on WIFI Calling
8. Reboot your phone

Wait few minutes you will see volte will be replaced by vo-wifi .
 

sanke3

I got banned!
Messages
312
Location
NA
ISP
MTNL FTTH
I have dual sim phone where Sim1 is Airtel and Sim2 is Jio. Airtel has no issue with activating VoWifi in Airplane mode however Jio's VoWifi gets activated only once after changing profile in QPST. After that, it doesn't activate again.
 
Messages
1,107
Location
NA
ISP
Airtel ftth
I tried enabling in mi a1 using this method

[GUIDE] Activate VoWiFi / WLAN Call

But getting this error " QMI connection not ready, please use USB driver version 1.00.32 "

Any suggestions , solutions ?
 
Messages
276
Location
Pune
ISP
You Broadband
Jio's network doesn't support VoWiFi officially on OnePlus handsets yet. So YMMV. Here's their official list - Jio VoWiFi calling

I just took a chance and enabled VoWiFi on my OP5 with Android 9..but no luck. ;) I think only OP6 and newer will be supported when the time comes.
 
Messages
76
Location
NA
@Ameen

According to OnePlus forums there devices support wifi calling but operator needs to enable it.

Jio tweeted that device is currently not compatible but they are working with the manufacture.