VoWiFi Support in Airplane Mode

Messages
5,067
Location
@socrateszero Mumbai
ISP
Jio Fiber. FTTH
I know that VoWifi does not work in areoplane mode on most Android phone. But I noticed that during a VoWifi call if you go to aeroplane mode then, wifi AND VoWifi call shut off & I get this message
XUkGn1c.png

But I can switch on wifi again manually but no calls are allowed. This is on Asus Max Pro M1 running Android 9.
 
Last edited:
Messages
21
Location
NA
ISP
BSNL
lV6Z2Sp.jpg

Workin on iPhone Xs Max using JioFiber
 

sanke3

I got banned!
Messages
312
Location
NA
ISP
MTNL FTTH
I had seen a tutorial how to enable WoWifi in Airplane mode on OnePlus devices. But somehow I cannot find it even after a lot of googling.
 

sanke3

I got banned!
Messages
312
Location
NA
ISP
MTNL FTTH
Alright guys. I did it. VoWifi activated in Airplane Mode on my OnePlus 7

Calls and SMS incoming and outgoing working on both the numbers.

UbHGfCZ.jpg


Original Guide is here. But I have simplified the process below because that guide is as confusing as it gets.
  1. Download this zip as it contains LogKit and EngineeringMode apk. Install them both on your OnePlus phone.
  2. Dial *#800# -> oneplus Logkit -> Function Switch -> enable VoLTE switch & VoWifi switch & VT switch and then reboot your phone
  3. Go to Settings -> Wifi & Internet -> Sim & network -> Sim 1 -> enable VoLTE and Wi-Fi Calling switches. Do the same for Sim 2
  4. Use the Drivers and software from below and not from the above link as the drivers mentioned in the original post do not work.
  5. Correct QPST drivers here.
  6. Correct QPST software here.
  7. Install both the QPST software and drivers with default selections during setup.
  8. Connect your phone to USB port of your PC and dial *#801#
  9. Only enable Full-port switch
  10. Open "PDC" in your QPST start menu folder, best to do by right click & "run as administrator"
  11. In the drop down menu, chose your Qualcomm device. For me it was Qualcomm HS-USB WWAN Adapter 9091 yours can be different.
  12. In the list, Right click on Germany-VoLTE-Vodafone -> SetSelectedConfig -> Sub0
  13. Again Right click on Germany-VoLTE-Vodafone -> SetSelectedConfig -> Sub1
  14. Now just select Germany-VoLTE-Vodafone and click on Activate button at the bottom.
  15. Reboot your phone.
  16. Profit?
TBH it's extremely easy

Can someone report their findings?

Can someone report their findings?
 
Last edited:

sanke3

I got banned!
Messages
312
Location
NA
ISP
MTNL FTTH
@Joy I have edited my earlier post.
Now I will perform an OTA update to Android 10 OOS 10.3.0 to see if the settings stick or not.
Edit: This does not survive OTA update and we have to perform this hack after every software update till OnePlus fixes Vowifi and VoLTE profiles themselves for Jio and Airtel. However this hack survives Factory reset.
 


Last edited:

thadougamer

King of BSNL 😂
Messages
408
Location
NA
ISP
BSNL Broadband
The problem is with Jio. Airtel VoWiFi is working fine in airplane mode on my 5T. Can't share screenshot as I am unable to upload the same.