How to get 5GHz wifi speed using JioFiber?

abhi_jollyguy

New Member
Messages
4
Hi everyone,

Greetings!

I am new to this forum. I have GigaFiber connection from Jio and Jio has provided the router JCO110 and I have connected this router via LAN to LAN to the Airtel Huawei HG630a. I am able to connect to the Huawei HG630 as well as to the JCO110 both via WiFi in my mobile but the speed I am getting is of only 2.4GHz. Means only 2.4GHz is getting utilized of Huawei router whereas the Huawei router has 5GHz wifi band.

Kindly help.

Any help is appreciated.

Thank you!

Abhishek
 
Messages
332
Hi everyone,

Greetings!

I am new to this forum. I have GigaFiber connection from Jio and Jio has provided the router JCO110 and I have connected this router via LAN to LAN to the Airtel Huawei HG630a. I am able to connect to the Huawei HG630 as well as to the JCO110 both via WiFi in my mobile but the speed I am getting is of only 2.4GHz. Means only 2.4GHz is getting utilized of Huawei router whereas the Huawei router has 5GHz wifi band.

Kindly help.

Any help is appreciated.

Thank you!

Abhishek
What mobile you are using ?
 

abhi_jollyguy

New Member
Messages
4
Hi Abhishek,

What speed are you getting via 2.4ghz band?

Do you have any PC connected via LAN? If yes, how much speed do you get in it?

How much speed does 5ghz provide at the moment?
Right now, at the time of writing this post. I am getting 91Mbps via LAN.
 

socrates

Well-Known Member
Messages
3,414
Location
@socrateszero
Obviously it's not obvious as you had not mentioned it in your first post. There are many Jio fiber user who complain that they don't get the promised 100Mbps via wifi, sadly not knowing that their device/s don't support 5ghz. Even if you speak to jio they will ask similar questions.
Normally one gets 95- 99Mbps, you can check at different times of the day if you get 91 then you can call the blokes who installed it.
What I have done is there is a slight difference in the ssid's for both the band's. Normally it should automatically connect to 5ghz instead of 2.4ghz (it's so in my case, across devices). Try manually connecting to the 5ghz (assuming it's visible in 'wifi' in settings), you should get 95-99Mbps on 5ghz too. Also try connecting another wireless device to the 5ghz band incase you still can't connect your mobile.
BTW: According to TRAI, customers should get atleast 80% of the promised speed.
 
Last edited:

msingh

Regular
Messages
472
Abhishek,

I hope you have enabled bnad 5 on your other router because Jio one doesn't have
 

Top