Netlink Bridge Mode without port / mac reset

pothi

Active Member
Messages
740
Location
Srivilliputhur / Madurai (TN)
Bridge mode is very important for me. So, tried to get my hand dirty in order to configure it without the help of BSNL / LCO, as all are busy deploying new FTTH connection (even though, it is a village, but most likely due to complete failure of ADSL upon drizzling / rain).

I was provided with Netlink HG323RGW ONU. I expect that the following guidelines may work with other Netlink models too.

First things first: Take a backup of the working configuration at Management => Device Management => Config File Management => Download. It is an XML file. Name of the file in my case is "lastgood.xml". It may vary depending upon the model, hardware version and software version. Make sure you can open this file using your favorite file editor and see the actual value for "pppUser" and "pppPasswd". These are actually PPPoE username and password. Please know that some exchanges change the default password.

Next step is to prepare for the worst. The following things happened to me.

1. Complete shutdown of Netlink ONU. I can't even ping Netlink ONU from my router, like what @varkey mentioned at Configure Netlink in bridge mode , because as a complete stupid, I tried to clone to mac-address from Netlink ONU to router. @varkey even warned about it earlier. Solution: Reset ONU to default settings and then upload our backup configuration

2. Couldn't authenticate with BSNL server via PPPoE: It's normal. We can't expect everything to work on the first attempt. I used the settings posted by @varkey at Screenshot to use bridge mode with mac reset (only vlan ID is different). I was having a good hard look at the settings again. I understood what @varkey tried to do and what I tried to achieve. @varkey tried to use mac-address of his router via mac reset. On the other hand, I tried to use the existing mac-address of Netlink ONU to authenticate (of course using a third-party router).

Now for the actual steps:

On Netlink ONU, find out which ethernet port is connected to the router. In my case, ethernet 1 is connected to the router. Now, do the following...

1. Visit Netlink ONU's admin page (default username: admin, default password: stdONU101 - these may vary upon model and hardware/software version)
2. Visit Network => Internet
3. Choose "Bridge" for "Mode"
4. No need to change Vlan ID (the previous / existing vlan ID would be filled automatically)
5. Service Mode: "Internet"
6. Port Binding: Check "Port 1" and uncheck "Port 2" and uncheck "WLAN".

Step 6 is important. If you connected Netlink ONU with the router via ethernet 2, then please check "Port 2" and uncheck the other two.

Finally, click "Save/Apply" at the bottom of the page.

Visit your router's dashboard and fire-up a new PPPoE client connection. It'd get connected in its first attempt.

I hope that helps someone in the future.

A huge thanks to @varkey who has provided lots and lots of information about Netlink ONU throughout this forum. I couldn't have done what I did without him sharing his vast knowledge on FTTH and on Netlink ONU.

Good luck, everyone!

 

varkey

Well-Known Member
Messages
1,187
This is great news @pothi 🎉 Good to know that you got it working! 🎉

I understood what @varkey tried to do and what I tried to achieve. @varkey tried to use mac-address of his router via mac reset. On the other hand, I tried to use the existing mac-address of Netlink ONU to authenticate (of course using a third-party router).
Could you please clarify what you did differently? 🤔 You mentioned that cloning the Netlink ONT's MAC address to your router didn't work, if so how did it work? :confused:
 

pothi

Active Member
Messages
740
Location
Srivilliputhur / Madurai (TN)
Mac cloning is the first thing that I tried, even considering the consequences of it. I had to reset the modem and mac of router before proceeding.

The difference between your config and mine is the 6th step. In your config, you unchecked all three ports. It means that BSNL servers only see mac-address of your router. That's the correct procedure if we want to reset the mac-address in BSNL.

In my case, I wanted BSNL to see ONU's mac-address even when I use bridge mode. So, I checked port 1 at step #6.
 


varkey

Well-Known Member
Messages
1,187
I tried exactly as yours too, that is the corresponding port checked. But the problem was that if the cloned Mac address matched the Mac address of the ONT, I lose the entire connectivity to the ONT from the router. Perhaps the issue is with my openwrt device where it somehow doesn't work if the same Mac is on both ends.

Also, I unchecked all three to use VLAN binding, so that I can send both voice and internet vlans to my router and use a soft sip client on my smartphone.
 

varkey

Well-Known Member
Messages
1,187
This is how my my VLAN binding is set. Both voice and internet vlans through the same port.

 

pothi

Active Member
Messages
740
Location
Srivilliputhur / Madurai (TN)
I tried exactly as yours too, that is the corresponding port checked. But the problem was that if the cloned Mac address matched the Mac address of the ONT, I lose the entire connectivity to the ONT from the router. Perhaps the issue is with my openwrt device where it somehow doesn't work if the same Mac is on both ends.

Also, I unchecked all three to use VLAN binding, so that I can send both voice and internet vlans to my router and use a soft sip client on my smartphone.
Probably, I didn't put it correctly due to the length of the initial post.

When mac-cloning failed, I didn't try it again. I only configured the bridge mode from ONT, with port 1 checked. Once it worked, I didn't check other settings. I am yet to set the time zone, IP range, password, etc. I will see how things are with respect to binding when I have access to it in about an hour.
 


varkey

Well-Known Member
Messages
1,187
Yeah, perhaps check what's the WAN side MAC right now on the router. It is also possible that there is no MAC binding for PPPoE authentication. @vishalrao had mentioned earlier it is that way for him.

Also, another thing @vishalrao mentioned was that for him, just not configuring the WAN interfaces sets the modem in bridge mode by default. In this case we need to configure the VLAN etc on the main router.
 
Top