MTNL Mumbai Massive downtime; connection only works a few hours a day

Messages
17
Location
NA
ISP
You Telecom
I've had my connection since December, and pretty much the only problem I've had is the cable coming to my house from another building breaking a couple of times during the monsoon. However, I changed my plan from an 8mb/s 1499 to an 8mb/s 1999 on the 19th of August. By the 20th, they had changed my plan, but on the 21st my internet went down some time in the afternoon. It came back at approx 2AM and then went off sometime after 6AM. While the internet is off, the ADSL light on the modem blinks for around 15-20 seconds then goes off for a few minutes and repeats. I made a complaint, and waited till Monday. Nothing changed, and my complaint for some reason was marked resolved. It also appears that the internet comes on at around 2AM pretty much every time although it occasionally comes on during the day once or twice.

I went over to the exchange with my modem, and the guy checked the line internally and externally. When he connected the modem internally the ADSL light would stay green and the internet would work. Externally, the ADSL light would have the exact same 'blink for 20 seconds, stay off for 5 minutes" behaviour I was having at home. So despite the internet working at times, and my phone working as well, the exchange guy told me to explain all this to one of the linesmen and ask him to check my line from the box to my house.
I just did that today and the internet came back from 3PM to 7PM, then again went off. Any suggestions would be appreciated.

My line stats:

 
Messages
551
Location
Mumbai
ISP
MTNL Triband ADSL2+ 8Mbps 1690
Looks like from your stats, you live within few hundred meters from the exchange..... considering that your SNR is too low........ Definitely line problem.....

Get line checked from linesmen.... and change Modulation to ADSL2+ Annex M.... Dont use G.DMT for 8Mbps..... Its Max Rates can be low for 8Mbps......
 
Messages
17
Location
NA
ISP
You Telecom
If I tell the linesmen the connection has low signal-noise-ratio, will he know what I'm talking about and what to fix? Also, do I change the modulation from the exchange or do I also tell that to the linesmen?
 


Messages
82
Location
NA
Yep snr margin too low. At this rate i am sure you would be getting rattle rattle disturbance in your phone calls as well.
If you make a complain to broadband call center they will check your line and get it changed. Even if inside your house you need to .
Also do you have parallel line connection inside your house? It can cause disturbance.
 
Messages
17
Location
NA
ISP
You Telecom
Thanks for all the help so far but I've tried a few things and had weird results. I live about 800-900m from the exchange and I don't have a parallel connection in my house, but there is a single line coming from some building that goes to my house and one neighbour above.

I didn't have a chance to get the linesman today, so I tried changing the modulation settings during the day when the ADSL light only flashes. I changed the modulation to ADSL2+ ANNEX M and the ADSL light became solid green, but no internet light. The line stats when I did that:


Unfortunately, when the line usually comes back at around 2AM, it didn't this time, so I tried changing the modulation settings back to G.DMT and ANNEX A, and almost instantly the ADSL and internet lights were green. Line stats:

I'm pretty confused now.
 


Messages
17
Location
NA
ISP
You Telecom
The linesman checked at the junction box, checked outside my house also and said the line is ok, but I still have no solid ADSL light during the majority of the day. What the hell is wrong with these people and what am I supposed to do now?
 
Messages
17
Location
NA
ISP
You Telecom
A guy came yesterday, changed the line, did some stuff at the junction box and managed to get it to work. Then he said he had to check the line because some panel at the junction box was being replaced, and that the connection would go off once or twice and would come back, but after it went off it never came back and my phone line died as well.

Today morning the same guy comes, checks the modem lights again, gets the phone line working but my ADSL light is still completely dead. The guy says they have to try and get an above ground line or some nonsense for the internet to work. Are these guys just messing with me or could there actually be this much of a problem for something that was working perfectly till 2 weeks ago?